[XeTeX] XeTeX segmentation faults

Jonathan Kew jonathan_kew at sil.org
Tue Jun 15 09:27:52 CEST 2004

On 15 Jun 2004, at 1:34 am, musaf wrote:

> I have had XeTeX installed for a while. Yesterday I used version 0.80 
> to see how my LaTex file would look in Hoefler. It worked fine. Today 
> when I tried it again, I suddenly started getting segmentation faults.

So it used to work, but now it doesn't? Strange. Can you think of 
anything you've changed in your system configuration since originally 
installing XeTeX?

> I upgraded to 0.82, and still have the same error.
> So I thought I would test the sample files:
> $ xelatex test.ltx
> This is XeTeXk, Version 3.14159-2.1-0.82 (Web2C 7.5.2)
>  %&-line parsing enabled.
> entering extended mode
> (./test.ltx
> LaTeX2e <2001/06/01>
> Babel <v3.7h> and hyphenation patterns for american, british, 
> nohyphenation, lo
> aded.
> (/usr/local/teTex/share/texmf.tetex/tex/latex/base/article.cls
> Document Class: article 2001/04/21 v1.4e Standard LaTeX document class
> (/usr/local/teTex/share/texmf.tetex/tex/latex/base/size12.clo)) 
> (./test.aux)Segmentation fault
> $
> I get similar results for the Arabic, Hindi, and most other examples.
> For some reason, transforms.tex and CM-test.tex work just fine.
> Any clues on what to do?

Look in ~/Library/Logs/CrashReporter and see if there's a 
xetex.crash.log and/or xdv2pdf.crash.log file, there may be clues in 
there. If you'd like to send me the crash log, I might be able to tell 
where the problem is happening.


More information about the XeTeX mailing list