[Tugindia] Preview-LaTeX - help required

David Kastrup dak at gnu.org
Mon Mar 17 18:35:46 CET 2003

"Duvvuri Venu Gopal" <venugopal_duvvuri at rediffmail.com> writes:

> While installing the Preview-LaTeX-Xemacs ***.rpm the installation
> asked for some CD - I supplied the PCQ CDs but it did not recognise
> and I have to stop the installation abruptly.
> The Preview-LaTeX-emacs *** installed. The "Preview" item is appearing
> on the menu bar in emacs (tty based). But when I tried to view it the
> following message is coming:
> "Display geometry unavailable: Wrong type argument:
> number-or-marker-p, nil".

"Display geometry unavailable" is perhaps too cryptic an error
message, I apologize for it.  It means that preview-latex tries to
find out the features from the graphical display available to Emacs
and fails.  Which is hardly surprising when you are running a tty
based Emacs, and so no graphical features are available at all.  At
the present time, this means that preview-latex is useless under a
tty.  A future version will perhaps be able to do a few things with
the help of terminal text properties, but that's some way off yet.

> In the windows - (gnome)

Which isn't visible to a tty Emacs...

> the following is the last line in C-c C-` - "Preview-LaTeX exited
> abnormally with code 1"
> When I tried to view the document - it is showing only the
> equations.

Well, preview-latex has left the dvi file it has failed to display in
place, but this dvi file only contains the material intended to
appear in previewed regions.  Rerung LaTeX to get the correct dvi
file again.

> I think I don't have the XEmacs in my machine, because, today while
> going through the RPM package installed the XEmacs is unmarked. I
> tried to install it - but the same thing repeated - it is asking for
> some CD for some program.
> Any clues??

Since I have no idea what you are using, no.  If you actually can call
XEmacs (and it has been installed somehow without using RPM), it might
be an idea to try installing preview-latex-xemacs (in addition to the
installed preview-latex-common) with the additional --no-deps option
to rpm.

Of course, this will place the relevant files into directories where
the XEmacs RPM would expect them, so if your installed XEmacs happens
to expect them elsewhere, you would need to copy them around.

Honestly, if (and only if) you have a manually installed XEmacs, it
would be saner to install preview-latex manually, too: get the
.tar.gz file, unpack it into a suitable temporary directory, do
./configure --with-xemacs && make && make install
and you should be set.

You could also try to use a non-tty Emacs in a version of at least

Hope this helps,

David Kastrup, Kriemhildstr. 15, 44793 Bochum

More information about the Tugindia mailing list