[tlbuild] mktexfmt pdflatex.fmt does not find the mktexlsr.pl file

YuGiOhJCJ Mailing-List yugiohjcj-mailinglist at laposte.net
Sun Jan 24 01:21:31 CET 2016


I built texlive-20150521 from the source code tarball [1].
After that, I tried the pdflatex command that is a symbolic link to the pdftex command:
$ pdflatex test.tex 
This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015) (preloaded format=pdflatex)
 restricted \write18 enabled.

kpathsea: Running mktexfmt pdflatex.fmt
Can't locate mktexlsr.pl in @INC (@INC contains: //tlpkg //texmf-dist/scripts/texlive /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5 .) at /usr/bin/mktexfmt line 23.
BEGIN failed--compilation aborted at /usr/bin/mktexfmt line 25.
I can't find the format file `pdflatex.fmt'!
The problem is that the mktexlsr.pl file is not found.
So, I have installed the texmf tarball [2] containing this missing file.

Now, I have all the things I need:
$ ls -l /usr/bin/pdflatex 
lrwxrwxrwx 1 root root 15 Jan 24 00:59 /usr/bin/pdflatex -> /usr/bin/pdftex
$ find /usr/texmf-dist -name "mktexlsr.pl"

But I got the same error.
I think the problem is that "mktexfmt pdflatex.fmt" is looking for the incorrect path.
As you can see, it is searching at //tlpkg, //texmf-dist/scripts/texlive, /usr/local/lib/perl5, /usr/local/share/perl5, /usr/lib/perl5/vendor_perl, /usr/share/perl5/vendor_perl, /usr/lib/perl5 /usr/share/perl5 and .
I would like that it searches at /usr/texmf-dist/scripts/texlive.

Any proper way to do that?

Thank you.
Best regards.

[1] ftp://tug.org/historic/systems/texlive/2015/texlive-20150521-source.tar.xz
[2] ftp://tug.org/historic/systems/texlive/2015/texlive-20150523-texmf.tar.xz

More information about the tlbuild mailing list