[texworks] Problem with syncing between source and preview

David Saunders david at symplectic.demon.co.uk
Mon Feb 18 11:56:52 CET 2019


I have a long-term project using the memoir class, with one master file and several included files. I have been working on this for around eighteen months with no problems. Suddenly, however, I have a problem syncing with one of the included TeX files. When I right-click on the TeX file and select "Jump to PDF", nothing happens. When I right-click on the part of the pdf corresponding to that file and select "Jump to Source", I get the following error message:

Cannot read file "":

No file name specified

This happens with only one of the included files; there is no problem with the others.

As an experiment, I tried deleting all the extra files (.aux, etc), and also the pdf file. When I did this, and recompiled, initially everything worked correctly. But after the (approximately) third recompilation, the error reappeared on the same included file.

I'd be grateful for any advice.

David Saunders

----- configuration info -----
TeXworks version : 0.5r1361 (Debian)
Install location : /usr/bin/texworks
Library path : /home/david/.TeXworks/
pdfTeX location : /usr/bin/pdftex
Operating system : Linux Dell13-LUB 4.15.0-45-generic #48~16.04.1-Ubuntu SMP Tue Jan 29 18:03:48 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
Qt4 version : 4.8.7 (build) / 4.8.7 (runtime)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/texworks/attachments/20190218/e091a3b9/attachment.html>

More information about the texworks mailing list