[texworks] new experimental builds

Joseph Wright joseph.wright at morningstar2.co.uk
Sun Dec 20 16:55:50 CET 2009

On 20/12/2009 15:51, Jonathan Kew wrote:
> On 20 Dec 2009, at 15:42, Bruno Voisin wrote:
>> Le 20 déc. 2009 à 16:24, Joseph Wright a écrit :
>>> On Snow Leopard I have to "point" TeXworks at /usr/texbin to get things working. This didn't happen before: any idea why?
>> I'm not seeing that, things work "out of the box". What do you mean by "point TeXworks at /usr/texbin"? The latter is there at the top of the list by default in Preferences>  Typesetting>  Paths for TeX and related programs.
> Does the Restore Defaults button remove it, I wonder?
>> As every time I install a new version of TeXworks, I've started by removing ~/Library/TeXworks before launching the new TeXworks for the first time, so that a virginal TeXworks folder is recreated with updated defaults if the defaults have changed. (I merge my local changes -- only additional processing tools -- back afterwards.) Could this play a role here?
> I don't think so; I think you have the binary paths stored as part of the prefs file, which is separate from the various configuration files. Preferences are stored in a .plist file in ~/Library/Preferences/. If you were to delete that, I'm guessing you'd lose the /usr/texbin path.
> JK
> (Not at my texworks machine right now, to actually experiment...)

I tried "Restore defaults": doesn't help. I also tried deleting both 
~/Library/TeXworks and ~/Library/Preferences/org.tug. ... (whatever it's 
called!), still didn't work. I had to point the program at /usr/texbin 
in all cases.
Joseph Wright

More information about the texworks mailing list