[texworks] message from TeXworks user(MiKTeX)-undefined control sequence document class article

Charlie Sharpsteen chuck at sharpsteen.net
Fri Oct 30 01:25:03 CET 2009

On Thu, Oct 29, 2009 at 12:35 PM, Robert MacDonald <
robm at shearwaterscientific.com> wrote:

> I just installed Miktex 2.8 on a windows XP -SP3 machine. Miktex and
> TexWorks seem to run fine. But when I try to typeset a test document (see
> bellow), I get a spool of error messages. It seems as though the class
> article can not be found. I searched my harddrive for the the .cls file but
> could not find it.
> The last time I used Latex I remember I had to have the .cls file in the
> same folder as the .tex files. Can anyone point me in the right direction. I
> also tried using some alternate .cls files which I found in the tex/latex
> folder of the installation. These gave the same error.
> Any help appreciated.
> Rob

I didn't see your attached tex file (maybe my email filtered it). However, I
usually get the "undefined control sequence 'document class' " error when I
try to typeset a LaTeX document using a *TeX* compiler.

I think pdfTeX is the default compiler used by TeXworks unless you tell it
otherwise. You should be using the pdfLaTeX compiler to typeset a LaTeX
document-- is this what is selected in the drop-down menu next to the
"Typeset" button?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/texworks/attachments/20091029/d7b03c38/attachment.html>

More information about the texworks mailing list