[texshop] TeXShop 4.18

Bruno Voisin bvoisin at icloud.com
Sat Dec 1 22:18:37 CET 2018

> On 1 Dec 2018, at 20:22, Justin C. Walker <justin at me.com> wrote:
> I tried to check for updates on the more recent version (the 4.18 version announced only on this list) [out of curiosity more than anything].  I got an “Update Error” alert that told me this:
> "TeXShop can't be updated, because it was opened from a read-only or a temporary location. Use Finder to copy TeXShop to the Applications folder, relaunch it from there, and try again.”
> Never saw that before.  I then quit TeXShop and renamed it to the original, and tried again.  Same error.
> There’s an obvious work-around, but I was (like the dead cat) curious: anyone seen this before?  Nothing significant has changed on this system (an iMac Pro running 10.13.6) in recent weeks, and the Sparkle scheme has generally worked, and never had a problem like this.
> The error message seems incorrect to me: the App is not in a read-only directory, or in a temporary location.  It is in a directory owned root/admin; my primary group is admin, the protections on that directory are 775, and I own the App itself.

I've not seen the same error message, but for some time now, every time there's a Sparkle TeXShop update, authentication is asked for at some point, which I found odd given I didn't think TeXShop involved anything at the OS level.

I thought this was because /Applications/TeX was owned by root, but you seem to say this is normal and of no consequence, so I don't know.


More information about the texshop mailing list