[texshop] TeXShop 4.18

Justin C. Walker justin at me.com
Sat Dec 1 20:22:55 CET 2018

Hi, all,

> On Dec 1, 2018, at 08:45 , Richard Koch <koch at uoregon.edu> wrote:
> Folks,
> TeXShop 4.18 is now available via the Sparkle update procedure and from
> 	http://pages.uoregon,edu/koch/texshop/texshop.html

This may be a result of shooting myself in the wrong foot, but while fooling around with new versions of TeXShop over the past couple of weeks, I ended up with two versions (both in /Applications/TeX/).  They had different names on the file system (like TS1 and TS2) while I was in the middle of fiddling, and I neglected to change the name of one to the original.

I tried to check for updates on the more recent version (the 4.18 version announced only on this list) [out of curiosity more than anything].  I got an “Update Error” alert that told me this:

"TeXShop can't be updated, because it was opened from a read-only or a temporary location. Use Finder to copy TeXShop to the Applications folder, relaunch it from there, and try again.”

Never saw that before.  I then quit TeXShop and renamed it to the original, and tried again.  Same error.

There’s an obvious work-around, but I was (like the dead cat) curious: anyone seen this before?  Nothing significant has changed on this system (an iMac Pro running 10.13.6) in recent weeks, and the Sparkle scheme has generally worked, and never had a problem like this.

The error message seems incorrect to me: the App is not in a read-only directory, or in a temporary location.  It is in a directory owned root/admin; my primary group is admin, the protections on that directory are 775, and I own the App itself.

Thought?  Clues?

Thanks, as always.


Justin C. Walker
Network, n., Difference between work
charged for and work done

More information about the texshop mailing list