pdflatex.fmt/install-tl-windows failures

Peter Flynn peter at silmaril.ie
Mon Apr 13 00:01:33 CEST 2020

On 12/04/2020 16:10, Michael Barr, Prof. wrote:
> I have solved the problem.  Since the computer is new it has to be a
> late version of Win-10 and it almost immediately upgraded.  The
> first thing I do when I get a computer is install a 3rd party command
> processor, TakeCommand. I tried running the tl-install from there. 

Ah. This would have been important information to start with.

> When I tried running from windows (file explorer), the first thing it
> did was ask if I wanted to allow it to change things.  This step was
> somehow bypassed when I ran it from the command line. 

At a wild random guess, TakeCommand asks for Admin access when you 
install it, so it is subsequently able to do things unchallenged that 
you would otherwise be prompted for. A side-effect of this could well be 
failing to install things in the expected places.

> Anyway, it finally installed and I tested a sample and it runs fine.

Excellent. Well tracked down, and thanks for letting us know.

> What would have happened from the DOS command.com I do not know and
> am not willing to test it.

It would have installed normally without any problems; we already know 
that, so there would be no reason to test it.


More information about the texhax mailing list.