problem with new MikTex and new emacs installations

Christopher W. Ryan cryan at
Tue Apr 2 16:40:49 CEST 2019

I'm probably in over my head.  Also, I'm not at that computer right now.
But trying to remember from yesterday:

1. When I compiled a tex document in the newest Goulet emacs using tex
-> pdf, I got the error about "Symbol TeX p" something.  But when I
instead used tex -> dvi -> ps -> pdf, everything worked fine.

2. Does the -Q switch disable all the AUCTeX add-ons?  If so, then how
was I able to run pdflatex with C-c C-c (defaults to pdflatex) ENTER? I
thought that key sequence was part of AUCTeX, not emacs itself.



Peter Flynn wrote:
> On 01/04/2019 22:07, Christopher W. Ryan wrote:
>> At any rate, using the -Q switch to start plain vanilla emacs 26.1,
>> 64-bit, and compiling the my MWE with C-c C-c ENTER (which defaults to
>> pdflatex), things seem to go OK.
> OK, so there is no problem with TeX itself.
> It's either an Emacs package clash, or the AUCTeX packages for Emacs.
>> It creates foo.pdf, foo.aux, and foo.log.  Here is contents of foo.log:
> That looks fine.
>> FWIW, I've also discovered that a tex -> dvi -> ps -> pdf workflow in my
>> new emacs installation works fine; it's the tex -> pdf workflow that
>> seems to have the trouble. 
> But the tex -> pdf above worked fine. Or do you mean the workflow
> imposed by AUCTeX? That seems to be where it tries to detect success.
> Does AUCTeX use latexmk to compile with?
>> Also, compiling a simple org-mode file
>> directly from emacs to pdf works without error.
>> I will have to scour my .emacs file closely.
> I still haven't fully resolved my issues, and it took a friend who is a
> serious elisp guru to do enough to get me started. It might not be your
> .emacs at all — in my case it was a conflict between one of Emacs'
> standard load files and one of the more recent defaults for nxml.
> Peter

More information about the texhax mailing list