[texhax] can't find input file?

Eric Abrahamsen girzel at gmail.com
Tue Feb 9 09:42:02 CET 2010

Okay, I may have figured it out. I should have been compiling the  
document with "xelatex" rather than "xetex", which I didn't realize  
when I started trying to debug from the command line. The problem  
isn't with my TeX installation, but rather than Emacs/Auctex seems to  
be using the "xetex" command to compile the file, even though LaTeX- 
XeTeX-command is set to "xelatex".

At least I have a better sense of where the problem lies! (and am able  
to keep working while continuing to debug).


On Feb 9, 2010, at 6:39 AM, Reinhard Kotucha wrote:

> On 8 February 2010 Eric Abrahamsen wrote:
>> I've been working on a tex file recently that makes use of two style
>> files, one of which loads the other. I want to use these style files
>> for other tex files, so this morning I tried putting them some place
>> on my system where they'd be located automatically by my latex
>> installation (I'm using MacTex 2009).
>> I can't be sure, but it seems like as soon as I moved the style  
>> files,
>> I started getting the error that LaTeX couldn't find my input file
>> (called "northern.tex" in this case). Not that it couldn't find my
>> style files, but the input file itself. I assumed the error message
>> was borked somehow and continued moving the style files to various
>> places around my system and messing with environment variables.
> Did you update the file database?  You have to do it whenever you move
> a file within the texmf* trees or add a new one.
> You just have to run the program mktexlsr.
> Regards,
>  Reinhard
>> Nothing worked, so I put the style files back in the directory with
>> the input file. Same error. The input file is very obviously there,
>> and not empty, and yet both Auctex via Emacs and the command line say
>> they can't find the input file. I've removed the \usepackage commands
>> and all custom commands from the input file, so it's basically just a
>> standard LaTeX file with nothing but text. Same error with XeTeX and
>> LaTeX. Here's the XeTeX log output:
>> This is XeTeX, Version 3.1415926-2.2-0.9995.2 (TeX Live 2009)
>> (format=xetex 2009.11.7)  8 FEB 2010 17:23
>> entering extended mode
>>  %&-line parsing enabled.
>> **northern.tex
>> ! Emergency stop.
>> <*> northern.tex
>> End of file on the terminal!
>> No pages of output.
>> How can it reach end of file when the file's right there in the
>> directory?
>> Help!
>> Eric
>> _______________________________________________
>> TeX FAQ: http://www.tex.ac.uk/faq
>> Mailing list archives: http://tug.org/pipermail/texhax/
>> More links: http://tug.org/begin.html
>> Automated subscription management: http://tug.org/mailman/listinfo/texhax
>> Human mailing list managers: postmaster at tug.org
> -- 
> ----------------------------------------------------------------------------
> Reinhard Kotucha			              Phone: +49-511-3373112
> Marschnerstr. 25
> D-30167 Hannover	                      mailto:reinhard.kotucha at web.de
> ----------------------------------------------------------------------------
> Microsoft isn't the answer. Microsoft is the question, and the  
> answer is NO.
> ----------------------------------------------------------------------------

More information about the texhax mailing list