[texhax] can't find input file?

Eric Abrahamsen girzel at gmail.com
Tue Feb 9 04:07:49 CET 2010

Thanks for all the responses! The difficulties continue but the error  
messages keep shifting slightly, and it's driving me crazy. I'm  
putting aside Emacs/Auctex for the moment and just using the command  
line. I've stopped with northern.tex and created a tiny test document,  
bob.tex, which also refuses to compile. Here's my Terminal session,  
tell me if I'm crazy:

(eric)~ $ cat bob.tex

This is the simplest possible document.
(eric)~ $ xetex bob.tex
This is XeTeX, Version 3.1415926-2.2-0.9995.2 (TeX Live 2009)
entering extended mode
! Undefined control sequence.
l.1 \documentclass
? ^D
! Emergency stop.
l.1 \documentclass
No pages of output.
Transcript written on bob.log.
(eric)~ $ pdflatex bob.tex
This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009)
entering extended mode
LaTeX2e <2009/09/24>
[[ snipped ]]
Output written on bob.pdf (1 page, 13924 bytes).
Transcript written on bob.log.

Latex and pdflatex compile correctly from the command line, but from  
within Emacs tell me they can't find the input file. XeTeX and TeX  
both produce the above error from the command line, and also from  
within Emacs.

I have no idea why the error messages are now slightly different than  
they were before, it seems to be because I switched from northern.tex  
to this simpler test document.

I know this must be something moronic that I did, but I can't imagine  

Thanks again,

On Feb 9, 2010, at 6:39 AM, Reinhard Kotucha wrote:

> On 8 February 2010 Eric Abrahamsen wrote:
>> I've been working on a tex file recently that makes use of two style
>> files, one of which loads the other. I want to use these style files
>> for other tex files, so this morning I tried putting them some place
>> on my system where they'd be located automatically by my latex
>> installation (I'm using MacTex 2009).
>> I can't be sure, but it seems like as soon as I moved the style  
>> files,
>> I started getting the error that LaTeX couldn't find my input file
>> (called "northern.tex" in this case). Not that it couldn't find my
>> style files, but the input file itself. I assumed the error message
>> was borked somehow and continued moving the style files to various
>> places around my system and messing with environment variables.
> Did you update the file database?  You have to do it whenever you move
> a file within the texmf* trees or add a new one.
> You just have to run the program mktexlsr.
> Regards,
>  Reinhard
>> Nothing worked, so I put the style files back in the directory with
>> the input file. Same error. The input file is very obviously there,
>> and not empty, and yet both Auctex via Emacs and the command line say
>> they can't find the input file. I've removed the \usepackage commands
>> and all custom commands from the input file, so it's basically just a
>> standard LaTeX file with nothing but text. Same error with XeTeX and
>> LaTeX. Here's the XeTeX log output:
>> This is XeTeX, Version 3.1415926-2.2-0.9995.2 (TeX Live 2009)
>> (format=xetex 2009.11.7)  8 FEB 2010 17:23
>> entering extended mode
>>  %&-line parsing enabled.
>> **northern.tex
>> ! Emergency stop.
>> <*> northern.tex
>> End of file on the terminal!
>> No pages of output.
>> How can it reach end of file when the file's right there in the
>> directory?
>> Help!
>> Eric
>> _______________________________________________
>> TeX FAQ: http://www.tex.ac.uk/faq
>> Mailing list archives: http://tug.org/pipermail/texhax/
>> More links: http://tug.org/begin.html
>> Automated subscription management: http://tug.org/mailman/listinfo/texhax
>> Human mailing list managers: postmaster at tug.org
> -- 
> ----------------------------------------------------------------------------
> Reinhard Kotucha			              Phone: +49-511-3373112
> Marschnerstr. 25
> D-30167 Hannover	                      mailto:reinhard.kotucha at web.de
> ----------------------------------------------------------------------------
> Microsoft isn't the answer. Microsoft is the question, and the  
> answer is NO.
> ----------------------------------------------------------------------------

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/texhax/attachments/20100209/0bb9fb80/attachment-0001.html>

More information about the texhax mailing list