[texhax] Argument of \@citex has an extra }

martin f krafft madduck at madduck.net
Sat Oct 13 11:58:07 CEST 2007

also sprach Donald Arseneau <asnd at triumf.ca> [2007.10.12.2157 +0100]:
> > \citet{AmorEtAl:2005:MLSUD3aaCSPR} find 
> \citet defined by what package, and used in what context??!?

Hi Donald, I appreciate your time in replying to me. I have still
not solved the problem and it's driving me insane!

I use natbib. Sorry for not thinking and including this from the

> Fragile command in moving environment.  Use better packages or
> \protect.

I have no idea what this means. I checked out
and my guess now is that a fragile command is used within the
bibliography, and it breaks as it's being moved into the main
document due to the cite.

But when I look at the two citations which cause trouble (all other
253 in my document work fine), I cannot find a command. I have tried
replacing the complex author string with John Doe, and I have
removed the braces around the D in Debian, but I always get the same

I have moved the \cite around in the document, but no matter where
it occurs, the error still happens.

I have swapped other references into the same cite, and then the
error went away!

So it has to be something about the bibtex entries, which are:

  author = {Juan-José Amor-Iglesias and Jesús M. González-Barahona and Gregorio
	Robles-Martínez and Israel Herráiz-Tabernero},
  title = {Measuring Libre Software Using {D}ebian 3.1 (Sarge) as a Case Study:
	Preliminary Results},
  journal = {UPGRADE: the European Journal for the Informatics Professional},
  year = {2005},
  volume = {6},
  pages = {13--6},
  number = {3},
  month = {June},
  file = {Full paper:AmorIglesiasEtAl\:2005\:MLSUD3aaCSPR.pdf:PDF},
  owner = {madduck},
  timestamp = {2007.10.11}

  author = {Juan-José Amor-Iglesias and Gregorio Robles-Martínez and Jesús M.
	González-Barahona and Israel Herráiz-Tabernero},
  title = {From Pigs to Stripes: A Travel through {D}ebian},
  booktitle = {Proceedings of the 6th Debian Conference},
  year = {2005},
  address = {Helsinki, FI},
  month = {June},
  file = {Full paper:AmorIglesiasEtAl\:2005\:FPtSATtD.pdf:PDF},
  owner = {madduck},
  timestamp = {2007.10.11}

> >   l.403 \cite{AmorEtAl:2005:MLSUD3aaCSPR}
> That is \cite, not \citet, on line 403 of a file (possibly an .aux file).

I tried with citet and cite and I got the same problem in both. Then
again, natbib probably overrides it.

So I disabled natbib and replaced \citet/p with plain \cite, and of
course the problem went away.

I will file a bug against natbib about this, but I first have to
understand the issue.

I appreciate your help!

martin;              (greetings from the heart of the sun.)
  \____ echo mailto: !#^."<*>"|tr "<*> mailto:" net at madduck
"science without religion is lame,
 religion without science is blind."
                                                    -- albert einstein
spamtraps: madduck.bogus at madduck.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature (see http://martin-krafft.net/gpg/)
Url : http://tug.org/pipermail/texhax/attachments/20071013/cdbac0ed/attachment.bin 

More information about the texhax mailing list