[texhax] xdvi-motif.bin build problems

Richard David Sherman rdsherman at adelphia.net
Fri Nov 16 02:10:23 CET 2007

Early this year I installed TexLive 2007. I didn't like the
xdvi-xaw.bin appearance so I pasted into the Tex tree a
xdvi-motif.bin that I found in my Slackware tetex package.
All has worked fine! It's a v22.84.9.

Recently I saw a much newer xdvik on CTAN. So I downloaded
v22.84.13. It configured, but 'blew up' on make. It said
that /usr/include/stdint.h had a duplicate unsigned def.

So I gave up and tried v22.84.12. It built without errors
and I copied xdvi-motif.bin and the xdvi shell wrapper
into my bin dir. A test of a complex Latex doc seemed
to indicate all was just perfect. I really liked the
new 3D buttons. But, when a print was ordered, either
by key or mouse, the ap 'crashed'. Here's the error message
left on stdout.

   xdvi-motif.bin 22.84.12 (Motif toolkit): events.c:4222:
   Shouldn't happen: Segmentation fault
        - trying to clean up and aborting ...

I tried moving in new config files, running texhash, applied
the patches, etc to no avail. I did NOT attempt to replace
the kpathsea-type binaries, however.

So I'm back to my old version. What am I doing wrong?

By the way, it would be nice if you added a xdvi-motif.bin
when you release TexLive 2008.

Here's my configure options

./configure --prefix=/usr/share/tex \
	--datadir=/usr/share/tex \
	--disable-a4 \
	--without-texinfo \
	--without-cjkutils \
	--without-musixflx \
	--with-ps=gs \
	--with-system-t1lib &> configureLog

Thanks for the assistance. You may forward this email as you
see fit.

Richard David Sherman

More information about the texhax mailing list