[texhax] TeX/UNIX

Pillai, Ravi Pillai_Ravi at GSB.Stanford.EDU
Wed Oct 25 02:20:43 CEST 2006

Hi folks,

Thanks for the responses to Linda's email.  I thought I'd take over from
Linda here, since this appears to be a problem with our Unix tetex-3.0
installation, and not a problem with the user's .tex files.

This is what we have so far ...

...[1] The problem goes away when the actual path is specified, instead
of the env variable. That is:

  \input  /actual/unix/path/bookdef 

  works fine -- so there is no problem with the user's bookdef.tex file.

...[2] The env variable problem occurs with both TeX and LaTeX (the
earlier report that it worked with LaTeX turned out to be untrue).

...[3] I got a "can't find file" error when I tried the test that
Reinhard and Karl had run successfully. That is:

  $ touch $HOME/junk/bookdef.tex

  $ tex '\relax\input  $HOME/junk/bookdef  \end' 

  This is TeX, Version 3.141592 (Web2C 7.5.4)
  ! I can't find file `$HOME/junk/bookdef'.
  <*> \relax\input $HOME/junk/bookdef 
  Please type another input file name: /dev/null
  No pages of output.
  Transcript written on null.log.

...[4] The above command worked fine when I substituted the actual Unix
path for $HOME on the command line.

...[5] Just for fun, I also tried using the tilde character instead of

  $ tex '\relax\input  ~/junk/bookdef  \end'   

  This is TeX, Version 3.141592 (Web2C 7.5.4)
  (/usr/pubsw/lib/texmf/tex/latex/tools/.tex File ignored) [1]
  Output written on .dvi (1 page, 224 bytes).
  Transcript written on .log.

In this case, it produced a file called ".dvi" (no name, only the
extension). This dvi file contained exactly one line of text:


... and that will serve as my exit line.  



P.S: Let me know if there's any other info you would like us to provide.
Thanks again for taking the time to check this out.

-----Original Message-----
From: reinhard.kotucha at web.de [mailto:reinhard.kotucha at web.de] 
Sent: Monday, October 23, 2006 5:05 PM
To: Bethel, Linda
Cc: support at tug.org; Pillai, Ravi
Subject: Re: [texhax] TeX/UNIX

>>>>> "Bethel," == Bethel, Linda <lbethel at exch-gsb.stanford.edu> writes:

  > Hello.  We have some plain TeX files on our UNIX system. Within
  > the file, we have tried to input another file using an environment
  > variable, for example \input $tx/bookdef. TeX is unable to find
  > the file, though LaTeX is. Do you know if there has been a change
  > in Plain TeX, making it unable to read these variables? Thank you
  > very much for your time and consideration.

I can't reproduce your problem:

 | $ touch $HOME/foo
 | $ tex '\relax\input $HOME/foo \end'
 | This is TeX, Version 3.141592 (Web2C 7.5.5)
 | (/home/reinhard/foo)
 | No pages of output.
 | Transcript written on foo.log.

Obviously "$HOME" has been expanded to "/home/reinhard" and the file
had been included.

Please note that after the filename a space is required.

LaTeX's \input command allows you to use either LaTeX or plain TeX

  \input{foo.bar}  %% preferred in LaTeX


  \input foo.bar  %% A space token denotes the end of the filename.

However, it is certainly easier to find out what is going wrong if you
send us your .log file.  Maybe something had been changed some time
ago.  I remember that it had been discussed on a mailing list but I
don't remember any details.

BTW., it would be nice if you can tell your mail program to avoid
HTML.  Nobody needs it but it blows up hundreds of mailboxes and the
list server has to deliver the needless stuff to hundreds of people...


Reinhard Kotucha			              Phone:
Marschnerstr. 25
D-30167 Hannover
mailto:reinhard.kotucha at web.de
Microsoft isn't the answer. Microsoft is the question, and the answer is

More information about the texhax mailing list