[texhax] Any PPCHTeX users out there?

romeomedina at libero.it romeomedina at libero.it
Sat Apr 16 14:05:36 CEST 2005

Rodolfo wrote:  
> I subscribed to both PPCHTeX and Tetex mailing lists to ask for help,  
> but they seem to be not active.  
> I freshly installed tetex-src-3.0.tar.gz in my Mandrakelinux 10.1   
> Community box,   
> in order to run PPCHTeX  
> to type chemical structure formulas.  
> Now, if I run TeX (onto a file containing PPCHTeX pictures)  
> from within the directory /usr/local/teTeX/bin/i686-pc-linux-gnu,  
> where the executable file `tex' is present, everything goes fine;  
> instead, if I run TeX from my home directory, I get the message:  
> ! TeX capacity exceeded, sorry [text input levels=15].  
> Can anyone explain these two different behaviours and suggest how to work  
the problem out?  
Karl Berry wrote:  
> Obvious question, but are you running the same tex binary in both cases?  
> Did you set PATH to include the directory with that `tex' before others?  
Yes, I think so. In fact, I created a symbolic link from the  
`/home/rodolfo/bin' directory to the file  
this way:  
[rodolfo at localhost rodolfo]$ echo $PATH  
$ export  
$ mkdir /home/rodolfo/bin  
$ cd /home/rodolfo/bin  
$ ln -s /usr/local/teTeX/bin/i686-pc-linux-gnu/tex tex  
. Then I did: `$ tex', and this was the output:  
[rodolfo at localhost rodolfo]$ tex  
This is TeX, Version 3.141592 (Web2C 7.5.4)  
, which is the same output I get if I do: `# ./tex'  
from within the directory `/usr/local/teTeX/bin/i686-pc-linux-gnu':  
[root at localhost i686-pc-linux-gnu]# ./tex  
This is TeX, Version 3.141592 (Web2C 7.5.4)  
. No other version of TeX is present on my machine.  
Karl Berry:  
> Any indication as to what files it is reading?  
> The log file might be helpful, for a start.  
The file is a very simple trial one, I called ppchtex.tex,  
with some PPCHTeX commands in it, which is perfectly processed by TeX if I do:   
`# ./tex /home/rodolfo/ppchtex' from `/usr/local/teTeX/bin/i686-pc-linux-gnu'.  
The log file can't help me, I'm attaching it.  
Thanks indeed for your help!,  

6X velocizzare la tua navigazione a 56k? 6X Web Accelerator di Libero!
Scaricalo su INTERNET GRATIS 6X http://www.libero.it
-------------- next part --------------
A non-text attachment was scrubbed...
Name: =?iso-8859-1?Q?ppchtex.log?=
Type: text/x-log
Size: 6938 bytes
Desc: not available
Url : http://tug.org/pipermail/texhax/attachments/20050416/ddac6fd9/iso-8859-1Qppchtex.bin

More information about the texhax mailing list