[texhax] inexplicable LaTeX weirdness

Philip G. Ratcliffe philip.ratcliffe at uninsubria.it
Wed May 21 14:38:22 CEST 2003

> > > > ... When I tried to TeX I got Unreadable Control Sequence
> > > > documentclass{article}. When I tried the first paper, I got the
> > > > same. When I tried any document, I got the same.
> > > > I'm using OS 9 on a G4. My son installed some games over the
> > > > weekend - could some extensions be turned off?
> >
> > Doesn't seem to be anyhing to with extensions since TeX did run.
> >
> > > You've switched from using the LaTeX format to (Plain) TeX.
> >
> > I hate to differ but I think not; the error in theat case would read
> >
> > ! Undefined Control Sequence
> > l.1 \documentclass
> >                   {article}
> oh, come one -- this is a new user: i really don't believe that he's
> not simply mis-remembered the error message when sending his mail.
> > I suspect, since it says instead "Unreadable", that somehow your editor
or a
> > file-corrupting crash (or, oops, a virus) has inserted ascii control
> > characters into your file (possibly as the first character), neither TeX
> > LaTeX (nor any other flavour of TeX) lkes them.
> it's quite possible that oztex has an "unreadable" in one of its error
> messages (who can tell, since the sources are of course not public),
> but there's no tex error message that contains "unreadable" -- the
> only instances of the word in tex.web are in comments.

Well, I have to admit that you're probably right Robin - maybe Allen will
let us know.  However, something similar did happen to me once and I seemed
to remember an error message like that - but I was wrong, it's actually
something more like "... invalid charcter ...".

Anyway, maybe this is the basis for a suggestion: when reporting errors cut
and paste the actually message from the log file.  Although I suspect that
Robin's right again: it is probably just an OzTeX error message.

Cheers,  Phil

More information about the texhax mailing list