[tex4ht] problem with new dvisvgm 2.6, all svg fies have horizontal lines with no math showing.

Nasser M. Abbasi nma at 12000.org
Mon Sep 10 07:37:12 CEST 2018


Just finished compile of one large latex file.

This is the one I started yesterday. It took about 32 hrs.
(it seems slower this time than before).

But there is a big problem. This is using the new dvisvgm 2.6,
compiled from sources on Ubuntu with TL 2018.1. Had to use 2.6
due to size limitation of 2.5.

When I open any web page, all the math is just thin horizontal lines.
No actual math shows up. Here is screen shot


The SVG files are all generated. Hashing seems to work well,
as all the svg file names have the long hash name. But no math shows.
Tried on firefox and Chrome. Cleaned the cache, no help.

Could someone please have a look?

I put a zip file of the complete folder which contains
everything, and also dvi, idv. The main HTML is called index.htm,
in this folder:


There seems to be something got corrupted somewhere.

May be it is due to large size of the IDV or DVI. I do not

Here is an example of one SVG file:

<?xml version='1.0' encoding='UTF-8'?>
<!-- This file was generated by dvisvgm 2.6 -->
<svg height='4.55264pt' version='1.1' viewBox='8.363622 617.741461 63.517177 4.55264' width='63.517177pt' xmlns='http://www.w3.org/2000/svg' xmlns:xlink='http://www.w3.org/1999/xlink'>
<g id='page27' transform='matrix(1.15 0 0 1.15 0 0)'>
<use x='7.272715' xlink:href='#g17-102' y='541.125306'/>
<use x='13.787897' xlink:href='#g20-40' y='541.125306'/>
<use x='18.030335' xlink:href='#g17-120' y='541.125306'/>
<use x='24.265189' xlink:href='#g20-41' y='541.125306'/>
<use x='31.537874' xlink:href='#g20-61' y='541.125306'/>
<use x='43.052998' xlink:href='#g14-0' y='541.125306'/>
<use x='51.537874' xlink:href='#g17-120' y='541.125306'/>
<use x='57.772728' xlink:href='#g19-50' y='537.166488'/>
<use x='62.505043' xlink:href='#g17-97' y='541.125306'/>

The zip file in the above folder is large, about 250 MB.

I also put the DVI and IDV files outside the zip file
in the above folder in case you just need to look at
them without having to download the large zip file.

The command I used to compile the index.tex is

make4ht -ulm default -e ./new.mk4 -c ./nma.cfg
        -f html5+dvisvgm_hashes index.tex

So any one can try the same thing.

And I also put dvisvgm 2.6 I build as binary in the above
folder, just in case. It did build correctly, but who knows,
may be it using wrong font library. It was complicated to
build from sources, but that was only way to get 2.6 without
having to wait one year for TL 2019.

This is very frustrating. I have not been to convert this latex
to HTML for more than 2 weeks now. Nothing seems to work for
some reason. Tried mathjax with make4ht, but that also did not
work for this file.

Any suggestions what to try?

>which dvisvgm

>dvisvgm --version
dvisvgm 2.6

Thanks for any help.

TL 2018 on Ubuntu


More information about the tex4ht mailing list