TL 2023 under Docker fails

Julien Dutant julien.dutant at
Wed Mar 22 19:39:09 CET 2023

Thanks Lars. I do understand the first error: the “local” Tex Live is older than the repository. That is because the repository has moved on to 2023, while my “local” installation is still in 2022.

So, I should update the local installation, right? The problem is that this installation isn’t on my computer. It’s in an “Docker image”, which is an image of a virtual Linux machine with TexLive 2022 installed. I have to use it (no matter why), can’t go around that. However, I can do some things within it. For instance, I can launch update scripts, or set the tlmgr repository.

Above I’ve detailed how I tried two solutions. One is to do a minimal update with . The other is to set up a historic repo. Each gives me an error (neither of which is about the local tex live being older than the remote repository.)

In short, this is as if I’m given a new machine with Alpine Linux and TexLive 2022 installed. I would like to install a couple of packages, but I’d very much NOT erase the TL 2022 and reinstall the whole 2023 (in fact, I practically can’t).

Any pointers welcome…
Julien Dutant<>

From: Lars Madsen <daleif at>
Date: Wednesday, 22 March 2023 at 17:08
To: Julien Dutant <julien.dutant at>, tex-live at <tex-live at>
Subject: Re: TL 2023 under Docker fails
The installation in your docker image is using TeXLive 2022. It is now frosen and cannot be updated.

tlmgr: Local TeX Live (2022) is older than remote repository (2023).​

says it all

Lars Madsen

Institut for Matematik
Aarhus Universitet at math<>

From: tex-live < at> on behalf of Julien Dutant <julien.dutant at>
Sent: 22 March 2023 17:38
To: tex-live at <tex-live at>
Subject: TL 2023 under Docker fails

Hi all,

I'm having a problem running or updating a docker image containing TexLive 2022.

I'm running a docker image using TexLive 2022, pandoc/latex<>, on a server (GitHub actions). It worked until recently, but with the 2023 I get an error when I try to install packages within the image:

RUN tlmgr update --self --all \
    && tlmgr install dvisvgm

tlmgr: Local TeX Live (2022) is older than remote repository (2023).
Cross release updates are only supported with
  update-tlmgr-latest(.sh/.exe) --update
See for details.

The pandoc/latex<> Dockerfile is complex and I'd rather not rewrite it to use TexLive 2023. (Hopefully its authors update it soon.) I've tried instead to run the instructions Upgrade - TeX Live - TeX Users Group (<> to run the script within the image. I'm getting the following error:

Verifying archive integrity... All good.
Uncompressing TeX Live Manager Updater  100%
./ updating in /opt/texlive/texdir...
./ tlmgr version says this is TeX Live 2022,
./ and this updater script created: Mon Mar 13 23:19:59 CET 2023.
./ proceeding with tlmgr update.
./ updating /opt/texlive/texdir/bin/default ...
tar: default: Cannot stat: No such file or directory
tar: Exiting with failure status due to previous errors
./ no xz.[default][.exe] binary for /opt/texlive/texdir/bin/default in /tmp/selfgz116956/installer/xz.

Worth noting: within the image (an Alpine Linux), TeXLive is located at/opt/texlive. I haven't tried to move to /usr/local/texlive/2023/and updating PATH. Would that help?

MWE: Save the following as Dockerfile in some folder. Run `docker build .` (don't forget the dot, run this in the same folder as the Dockerfile). Note that the image only works on x86-64 architectures (i.e. Intel/AMD, not Apple Silicon).

# Dockerfile
FROM pandoc/latex:latest
# Install wget and bash, download and run it
RUN apk add wget bash \
    && wget -O \
    && bash
# If this worked, we would then update and install a couple of packages
RUN tlmgr update --self --all \
    && luaotfload-tool -fu \
    && tlmgr install \
    standalone \
ENTRYPOINT [ "/usr/local/bin/pandoc" ]

I've also looked at changing the repository to a historic 2022 repository. I've tried the following:

FROM pandoc/latex:latest
# Try to use the 2022 repo
RUN tlmgr option repository
# If this worked, we would then update and install a couple of packages
RUN tlmgr update --self --all \
    && tlmgr install \
    standalone \
ENTRYPOINT [ "/usr/local/bin/pandoc" ]

But I get an error because the historic repo doesn't have a `tlpkg` folder:

/opt/texlive/texdir/bin/default/tlmgr: TLPDB::from_file could not initialize from:<>
/opt/texlive/texdir/bin/default/tlmgr: Maybe the repository setting should be changed.

Any help welcome. I just need to be able to use tlmgr-install to install a couple of packages within a TeXLive 2022 docker image, any workaround will do.


julien dutant

Department of Philosophy, King's College London
julien.dutant at<mailto:julien.dutant at>


London WC2R 2LS

United Kingdom
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the tex-live mailing list.