[tex-live] texhash not updating ls-R-TEXLIVEDIST

Zdenek Wagner zdenek.wagner at gmail.com
Fri Dec 8 20:42:22 CET 2017

Hi all,

similar thing happened to me when I installed TeX Live as root, then added
texmf-local and placed some files there and created ls-R files as a normal
user, then updated TeX Live as root and then installed a few new files into
texmf-local as a normal user. During update even the ls-R files in
texmf-local were regenerated and now owned by root, therefore when
installing later files into texmf-local the ls-R could not be updated by a
normal user. So the problem is certainly in the ownership of the ls-R files.

And as George wrote, if you run a command in terminal, the setting of the
whole environment (including PATH) is taken from ~/.bashrc but if you write
it from a menu of a program started by GUI, the environment is taken from
~/.bash_profile, so you must ensure that both load the same settings. If
you change ~/.bashrc, it is sufficient to open a new terminal, if you
change ~/.bash_profile, you must log off and on. These are not bugs but
documented behaviour, see your Linux manual.

Zdeněk Wagner

2017-12-08 20:12 GMT+01:00 George N. White III <gnwiii at gmail.com>:

> On 8 December 2017 at 14:17, David Carlisle <d.p.carlisle at gmail.com>
> wrote:
>> On 8 December 2017 at 13:58,  <gml at garymlewis.com> wrote:
>> > Hi -
>> >
>> > This problem started with a "ebgaramond.sty not found" error when
>> running a
>> > tex file in TexMaker.
>> >
>> > Summary:
>> > ebgaramond.sty does not appear in ls-R-TEXLIVEDIST. Running sudo texhash
>> > does not add the sty file.
>> >
>> > Brief synopsis (reboots not identified):
>> > 1. Reinstalled OS (Ubuntu 16.04 LTS)
> This is very rarely useful and doesn't give you an opportunity to find a
> solution to
> the original issue.
>> > 2. Reinstalled complete texlive (as sudo).
> A better approach is to pick a texlive administrator (e.g., the regular
> user of a
> single-user systems), use "sudo" to create /usr/local/texlive and transfer
> ownership to the texlive administrator.   Now that it is installed, a
> "chown -R ..."
> can fix things.
>> > 3. Reinstalled TexMaker (as sudo).
> Did you use a package from the temaker site or somethings else?
> > 4. Added /usr/local/texlive/2017/bin/x86_64-linux to $PATH in .bashrc.
>> > 5. Ran sudo texhash.
>> > 6. Ran myfile.tex in TexMaker. Same error: ebgaramond.sty not found.
> Have you tried running texmaker from the command line where pdflatex
> works?  A GUI program started from a menu may not get the same PATH as
> a shell program.
> > 7. grep -i "ebgaramond.sty" ls-R-TEXLIVEDIST returns nothing.
>> > 8. But, running pdflatex myfile.tex from the command line works fine
>> (sty
>> > file is found).
>> >
>> > Is this a known bug? If not, what other information can I provide now?
>> >
>> > Thanks.
>> >
>> > Gary Lewis
>> I would guess that your editor is using the system tex that came with
>> ubuntu not finding the one you just installed. either because it is
>> using some explicit path like /usr/bin/pdflatex or because it is using
>> a different PATH
>> David
> I agree with David.  You might get better advice from the TexMaker
> site.
> --
> George N. White III <aa056 at chebucto.ns.ca>
> Head of St. Margarets Bay, Nova Scotia
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/tex-live/attachments/20171208/d76972b6/attachment-0001.html>

More information about the tex-live mailing list