[tex-live] dvipdfmx on CentOS 5.6 (glibc 2.5)

Karen Ellrick osakawebbie at gmail.com
Mon Apr 16 16:34:38 CEST 2012

Replies to various...

> (Karl) I am somewhat surprised that only dvipdfmx complains,
> since all the binaries were built on the same system.
Well, since the only other command I have even tried (uplatex) isn't 
part of your set of binaries, it might very well be that everything else 
in your binaries would complain.  I'm probably only going to use about 
three or four TeX-related commands ever - my main environment is PHP and 
online services, not publishing.

> (Norbert) Add the line
> 	#define JPVERSION "j1.41-ptexlive"
> just after the definition
> 	#define XDVI_VERSION "22.85"
> that is the only wrong thing.
That did the trick!  I'm looking at a beautiful PDF created by my fresh 
binaries run on Tanaka-san's sample tex file.  dvipdfmx complained a 
little as such:

    [root at vps-1011517-5697 ~]# dvipdfmx aozora-utarticle-utf8-1.dvi
    aozora-utarticle-utf8-1.dvi -> aozora-utarticle-utf8-1.pdf
    ** WARNING ** CMap has higher supplement number than CIDFont:
    ** WARNING ** Some chracters may not be displayed or printed.
    ** WARNING ** CMap has higher supplement number than CIDFont:
    ** WARNING ** Some chracters may not be displayed or printed.
    9924 bytes written

But if the resulting document is missing something, it's not obvious at 
first glance - I don't know if I need to solve those warnings or not.

> (Akira) Lets try X-window system later:
> ./Build --without-x --disable-mf
I don't need it anyway - I'm using a VPS, with my only access via SSH.  
So I took that suggestion too.  Even without those things, it took about 
an hour and a half to run Build.

If you would like a set of binaries from my machine for your 
"collection", I can build again with X-windows included - let me know if 
you would like that.

Can you suggest where I should put these binaries long term?  I see that 
there are a bunch of symbolic links to stuff like "../../something", so 
I know this is an important question.  The instructions on 
http://www.tug.org/texlive/build.html say to put them in 
Master/bin/<archname>, but the only Master directory I have is in 
/root/texlive, a temporary spot I created for unpacking something 
earlier (I can't remember which of the various download/install/build 
attempts that was).  My OS already has a lot of the TeX commands (no 
doubt versions that won't work for what I'm doing) in /usr/bin, but 
obviously that won't work for the new ones because of the links.  I do 
have the structure in place from when I ran install-tl, with set of 
binaries in /usr/local/texlive/2011/bin/x86_64-linux.  For now, I 
created a new directory "next door" at 
/usr/local/texlive/2011/bin/x86_64-unknown-linux-gnu - a couple of the 
links are bad in that location (pedigree and pmx), but I have no idea if 
they will matter to me, and I have no idea if the files that the rest of 
the links point to are appropriate versions and such.  Guidance is 

> (Reinhard) BTW, the # is *not* a comment character in .c and .h files.  They
> denote pre-processor directives.
Duh! (blush)  I honestly wasn't thinking carefully about what language I 
was looking at.  I haven't used C since the early 90's, so my memory is 
fading, and recently I was working on some bash scripts (which do use # 
for comments), so I got confused.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/tex-live/attachments/20120416/fd1c20f1/attachment.html>

More information about the tex-live mailing list