[tex-live] Problems with Nafees fonts

Ulrike Fischer news3 at nililand.de
Tue Aug 30 17:28:52 CEST 2011

Am Tue, 30 Aug 2011 16:56:26 +0200 schrieb Zdenek Wagner:

>>> from xdvipdfmx's output:
>>> <FONTMAP:pdftex.map><FONTMAP:cid-x.map>DVI Comment:  XeTeX output
>>> 2011.08.30:1558
>>> xxx.xdv -> xxx.pdf
>>> <AGL:texglyphlist.txt>[1<NafeesNastaleeq(Nafees:Regular)@20.66pt
>>> ** ERROR ** Cannot proceed without the "native" font: NafeesNastaleeq
>>> (Nafees Regular)...
>> So xdvipdfmx can't find it by name. I tried the font (" Nafees
>> Nastaleeq v1.02 beta") on windows with miktex and apart from some
>> warnings (** WARNING ** Invalid CMap mapping entry. (ignored)) it
>> worked fine.
>> Can xdvipdfmx use other fonts from this font folder?

> I tried Nafees Web Naskh (from the same font package) and I have the
> same error. I have quite a lot of fonts in directories under
> /usr/share/fonts, probable I have not tried all of them but generally
> what I tried, everything worked. Nafees fonts are the only problematic
> ones. AFAIK these fonts are popular for typesetting in Urdu and Farsi
> and I think someone uses them in XeLaTeX. Maybe this is some OS
> specific bug, I do not know.
> It has nothing to do with Arabic, I have SIL Sheherezade in a
> subdirectory of /usr/share/fonts and it works fine.

Well obviously xdvipdfmx can't find the font. I get the same error
message if I first generate the xdv, then remove the font, and then
call xdvipdfmx.

As you said that it works if you call the font by file name it can't
be an access problem or a outdated fc-cache problem. It must be
something related to the (internal) the name of the font but I don't
know what it could be. 

Ulrike Fischer 

More information about the tex-live mailing list