[pdftex] Incorrect pdf produced from a single correct pdf file

Olivier Cailloux mlsmg at ulb.ac.be
Mon Oct 6 14:47:49 CEST 2008

George N. White III a écrit :
> On Sat, Oct 4, 2008 at 4:09 PM, Olivier Cailloux <mlsmg at ulb.ac.be> wrote:
>> Thank you to all those who responded so quickly. I am still wondering is
>> someone can explain why the given tex file does not work for me when it
>> does work for others...
>> A few comments, concatenating all relevant replies.
>> Martin Schröder asks me why not doing it in LaTeX: as Andreas said, I am
>> indeed trying to merge the files using LaTeX (and I did not expect to
>> start a pdfTeX vs LaTeX war!). But it did not work with the pdfpages
>> package in LaTeX and I am trying to discover why. My post here is simply
>> to try to boil the problem down to some more precise problem.
>> The backslashes characters have been stripped from my post for an
>> unknown reason, as John Culleton noticed. Naturally they were present
>> when I compiled the tex file.
>> Thank you also for the alternative suggested tex commands, but it won't
>> help me as I am only trying to understand how come that the sample tex
>> file does not work for me where it correctly works for others.
>> Hartmut Henkel says that "the PDF in the attachment of your e-mail
>> contains in object no. 1 a broken LZW stream (but the RMItd24.pdf is
>> ok.). This can't be forced (easily) by macro programming, so it could be
>> some bug in the old pdfTeX version or its xpdf library used for creating
>> the PDF file. My current pdfTeX-1.50.0-alpha here doesn't produce a
>> corrupted PDF."
>> Very interesting remark. But I am still not convinced that this
>> is a version problem, as Andreas tells me that my sample .tex file works
>> for him on his system using the same pdftex and xpdf versions as I do
>> (except that, looking closely, he has version 3.141592-1.40.3-2.2 where
>> I have version 3.141592-1.40.3, what's this 2.2 behind?).
> Using TeX Live 2007 as provided by Red Hat Fedora 8:
> The page is blank except for the "1" at the bottom.  I also tried:

So the problem is indeed not Debian-specific, but I still think, or I
misunderstood something, that there is something specific to my (and
your) system. The RMItd24.pdf file is not the only culpable, as the same
command works on other' systems with the same RMItd24.pdf. Several
persons on this very mailing list confirmed this.

> If I do  epstopdf --outfile s.pdf RMItd24.pdf then the job works
> with s.pdf.   The problem is not distribution-specific.   PDF is a

Thank you, very useful information. pdftex also works for me with that
workaround, and I am now able to achieve the join operation with LaTeX
and the pdfpages package.

Although my specific problem is now solved, I still think there is a bug
somewhere in pdftex, or in a library used by pdftex on my system, or
something like that. If someone wants to investigate, I am still ready
to provide any information.

More information about the pdftex mailing list