[pdftex] Pdfpages used repeatedly produces 'unprintable' file.

Michael Chapman pdftex at mchapman.com
Wed Apr 13 06:01:47 CEST 2005

I have an document production routine that uses multiple (three) runs of 
I have previously used this routine with Chinese, Arabic and various Latin 
and Cyrillic languages.
Recently I tried this with Japanese.

Not sure whether it is the different set of ideographs or whether we have 
changed printer, but now (with an intranet, postscript printer with 600+ Mo 
of memory) we cannot print the output file.
XPP (on Linux) ties up the printer and then eventually times out.
Acroread (when asked to print) quite often just crashes.

I suspect that the 'problem' would be ?easily solved by forcing font 
inclusion in the last run, and forcing font exclusion in the earlier runs (to 
prevent multiple font embedding).
So this is not a plea for help, just a real life example that I thought might 
be of interest to others.

The initial file (about 50 pages of text) is 82,036,043.
Using pdf2ps on this produces a file that prints very smoothly, and has a 
size of 5,969,009 bytes.
The latter can be converted 'back' with ps2pdfwr and is then 2,516,978 bytes.

The 'new' file (at 3% of the size), not surprisingly, is much faster (on page 
changes, etc.) on acroread.

Not proud of this ... just thought the observations might help anyone else 
who 'paints themselves into the same corner'.

Michael Chapman

More information about the pdftex mailing list