[pdftex] (fwd) tetex-bin: pdftex/pdflatex fails to subset embedded CJK TrueType font

Hartmut Henkel hartmut_henkel at gmx.de
Mon Dec 13 23:14:04 CET 2004

On Mon, 13 Dec 2004, Hilmar Preusse wrote:

> here down in the Debian bug tracking system about two years ago we've
> got the following bug report[1].
> The example file and a log file is attached (log.txt is the screen
> output). I've tried with pdfTeX from teTeX beta-2.99.4
> (1.20b-rc3-2.2) and got the same results as in the report. The
> mentioned arphic.map of cource was copied to the right place in the
> tetex-beta tree. I've read pdftex-a.pdf and I couldn't found a
> statement, that subsetting is not possible in some cases.
> As mentioned in the report for compiling that file you need cjk-latex
> installed and the Arphic "AR PL Mingti2L Big5" fonts installed (ttf
> and tfm files). In Debian these fonst can be found in the packages
> ttf-arphic-bsmi00lp and tfm-arphic-bsmi00lp.
> Yes, there are encoding files as you can read in the log and the map
> file looks correctly too (not subsetting).
> Please keep the bug in Cc: (178717 at bugs.debian.org).

i can't repeat the example, as i don't have a running CJK environment.
But the same happens with a random "western" TT font, e. g.

\pdfmapline{+Packa___ <8r.enc <PackardAntique.ttf}
\font\Packa  Packa___ at 20pt
\input tufte

(the used encoding 8r.enc is nonsense for .ttf)


$ pdffonts x.pdf
name                                 type         emb sub uni object ID
------------------------------------ ------------ --- --- --- ---------
Packa___                             TrueType     yes no  no       6  0
RCFUQK+CMR10                         Type 1       yes yes no       9  0

But now comes the interesting part:

$ ls -l x.pdf PackardAntique.ttf
65120 2003-09-06  PackardAntique.ttf
11472 12-13 22:45 x.pdf

Doesn't the file size of the result suggest, that it's subsetted? Then
tried the same with a non-subsetted font:

\pdfmapline{+Packa___ <<PackardAntique.ttf}
\font\Packa  Packa___ at 20pt
\input tufte

$ ls -l x.pdf
37804 12-13 22:50 x.pdf

See the significantly larger file size.

$ pdffonts x.pdf
name                                 type         emb sub uni object ID
------------------------------------ ------------ --- --- --- ---------
Packa___                             TrueType     yes no  no       6  0
AUKISB+CMR10                         Type 1       yes yes no       9  0

Acrobat reader 5.0.5 woody i686 doesn't tell "subsetted" here for the
TTF, so there is a discrepancy between acroread and pdffonts. Also
interesting is that the acroread "Document Properties/Fonts" window
changes if one zooms around a little. Looks buggy.

So what is the criteria in the PDF file that the pdffonts tool or
acroread decides it's subsetted or not? No idea. It seems that pdftex
does in fact some kind of subsetting, and from the practical standpoint,
the PDF file with subsetted TT fonts is significantly smaller than the
one with fully embedded TT fonts.

Regards, Hartmut

More information about the pdftex mailing list