[pdftex] install pdftex 0.14h binary failed, please help.

Lupei Zhu lupei at usc.edu
Thu Apr 19 23:08:48 CEST 2001


  I want to update pdftex on my RH7.0 PC (which was installed 14d by
redhat). I did as follows:

1) download file from ftp.muni.cz
2) unzip it and copy pdftex.pool, pdfetex.pool to
/usr/share/texmf/web2c, copy those excutables to /usr/bin
3) in web2c, run texconfig init. I found that it only regenerated
several other *.fmt files but not pdf*.fmt. So when I tried to  run
"pdflatex ...", I got error complaining wrong format.
4) I used followings to regenerate format files:
   pdftex -ini -fmt=pdftex plain \dump
   pdftex -ini -fmt=pdflatex latex.ltx
   pdfetex -ini -efmt=pdfetex plain \dump
   pdfetex -ini -efmt=pdfelatex latex.ltx
   all worked fine.
5) now run "pdftex -version", I got:

pdfTeX (Web2C 3.14159-0.14h-released-20010417
kpathsea version
Copyright (C) 1999 Han The Thanh, Petr Sojka, and Jiri Zlatuska.

6) but when I try to compile a tex file by "pdflatex aaa.tex", I got
this error
This is pdfTeX, Version 3.14159-14h-released-20010417 (Web2C
Error: pdflatex (file pdftex.cfg): cannot open config file

  I find that if I copy the file
/usr/share/texmf/pdftex/config/pdftex.cfg to the current directory, the
above works. I tried to set the TEXPSHEADERS to point that directory, it
doesn't help.

  I am stuck here. can anyone please help me? thanks alot.


More information about the pdftex mailing list