[OS X TeX] hyperref problem

Herbert Schulz herbs at wideopenwest.com
Tue Jun 23 17:42:06 CEST 2020

> On Jun 23, 2020, at 10:20 AM, Nitecki, Zbigniew H. <Zbigniew.Nitecki at tufts.edu> wrote:
> Undoubtedly, but that goes way beyond my understanding of how the system works.
> Can you point me to a guide (for Dummies) on how to troubleshoot something like this?
> Zbigniew Nitecki
> Department of Mathematics
> Tufts University
> Medford, MA 02155
> telephones:
> Office    (617)627-3843
> Dept.    (617)627-3234
> Dept. fax    (617)627-3966
> http://www.tufts.edu/~znitecki/
>> On Jun 23, 2020, at 8:49, Herbert Schulz <herbs at wideopenwest.com> wrote:
>>> On Jun 23, 2020, at 7:37 AM, Nitecki, Zbigniew H. <Zbigniew.Nitecki at tufts.edu> wrote:
>>> I have realized something interesting about my hyper ref problem.
>>> I have always used the TeXShop viewer from within TeXShop—that is, I’ve opened a source file in TeXShop and then viewed the pdf file that comes up.
>>> For some silly reason, I just tried my test file OUTSIDE TeXShop—that is, opening either Preview or Adobe Acrobat, and opening only the pdf.  
>>> Then the links work fine.  
>>> So there is something glitchy in my copy of TeXShop—right?
>>> But now I have a different problem—or actually two.
>>> First, I tried again to use my newly uploaded MacTeX 2020 on the longer document that had originally exhibited my hyperref problem,
>>> and was getting a slew of error messages—looking closely at them, they seem to be problems with pstricks and/or pst-3D before I even get to my document
>>> in the typesetting process.  
>>> Second, when I reverted back to my older 2017 TexLive, which I had originally used to generate the longer document, the behavior was different from before,
>>> in that now I got a slew of error messaged for my pictures—which were generated using pst-ode, successfully on previous occasions—and if I did my usual and 
>>> typed “r” in the console and hit return, the paper typeset with no pictures.  
>>> So now I don’t have an electronic dopy of my paper as I originally managed to typeset it (of course, being naughty and ignoring warnings) and see no way to recover it.
>>> Zbigniew Nitecki
>>> Department of Mathematics
>>> Tufts University
>>> Medford, MA 02155
>> Howdy,
>> Could you have some old packages in your personal tree that are interfering with the new versions of other packages? How about the same in the texmf-local tree.
>> Good Luck,
>> Herb Schulz
>> (herbs at wideopenwest dot com)


The log file will list the full path of all packages as they load. Just look for packages that are coming from your personal or texmf-local tree and start to eliminate them. You personal custom packages don't count but anything loaded by them or other packages could be a culprit.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: https://sites.esm.psu.edu/~gray/tex/
List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the macostex-archives mailing list.