[OS X TeX] puzzling behavior

Nitecki, Zbigniew H. Zbigniew.Nitecki at tufts.edu
Wed Jun 10 02:41:09 CEST 2020

I don’t know if anyone can help me with this but I am at a complete loss as to what could be going wrong.

The attached source file, aside from setup, is to produce a single picture—a phase portrait for a homogenous second order system of llinear o.d.e.’s (constant coefficients) using the pst-0de package.  It is designed for testing tweaks for this program.

In the context of a larger document, this has worked to produced a substantial number of pictures.  The code is copied verbatim (command-C) from one of its appearances in that document, so there should be nothing intrinsically wrong, internally, with the code.  Just to check for possible problems with package calls, I have also copied verbatim the preamble to the large doecument in which this figure worked.

Nonetheless, this time when I try to compile, I seem to never get to having the program actually run, and I get an asterisk;  if I hit return on the console, I get the statement “type \end” and when I do I again get the asterisk,

To stress again, this identical block of code (from \begin{figure} to \end{figure}, in a larger document with the identical preamble runs fine, but isolated like
this, something is going wrong.  I can only surmise that the problem is somewhere in this “minimal” example.  Where to look?

If it helps, here is what the code is supposed to do:  it is plotting integral curves of the system of o.d.e.’s
x’ = Ax+By
y’ = Cx+Dy
inside a \picsize by \picsize box.  (The values of A,B,C,D, and \picsize are set in the body of the code), with the option of picking inotial conditions
at evenly spaced positions along the top, bottom, left  edge, and/or right edge of the box. As set right now, the top/bottom part is commented out,
and the active part is supposed to do x’=x, y’=y, starting at 24 places spaced 0.25 units apart (deliberately more than the 5x5 box, which clips the results).  The picture should look like the hyperbolas xy=C for various C.

There is a lot in the preamble (including calls to packages of my privately defined macros, which however are not needed for this particular picture)
but I’ve left everything in place to see if there is a conflict somewhere.  but again, these same package calls have worked fine when I run the whole document.

Zbigniew Nitecki
Department of Mathematics
Tufts University
Medford, MA 02155

Office    (617)627-3843
Dept.    (617)627-3234
Dept. fax    (617)627-3966

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/macostex-archives/attachments/20200610/dac96e42/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Figtest.tex
Type: application/octet-stream
Size: 5851 bytes
Desc: Figtest.tex
URL: <https://tug.org/pipermail/macostex-archives/attachments/20200610/dac96e42/attachment.obj>
-------------- next part --------------
----------- Please Consult the Following Before Posting -----------
TeX FAQ: http://www.tex.ac.uk/faq
List Reminders and Etiquette: https://sites.esm.psu.edu/~gray/tex/
List Archives: http://dir.gmane.org/gmane.comp.tex.macosx
TeX on Mac OS X Website: http://mactex-wiki.tug.org/
List Info: https://email.esm.psu.edu/mailman/listinfo/macosx-tex

More information about the macostex-archives mailing list.