[OS X TeX] Activating mtpro2 in Texlive 2012

Herbert Schulz herbs at wideopenwest.com
Tue Sep 4 21:00:28 CEST 2012

On Sep 4, 2012, at 1:52 PM, Themis Matsoukas <tmatsoukas at me.com> wrote:

> I installed TeX Live 2012 through the mactex package but I am unable to activate mtpro2 (PC TEX MathPro Lite), which worked in the previous installation. I am following Herb's instructions:
> 1. The fonts are installed in my personal tree: /Users/themis/Library/texmf/...
> 2. I created the file /Users/themis/Library/texmf/web2c/updmap.cfg with contents:
> #! Map belleek.map
> Map mtpro2.map
> 3. I run updmap on the terminal.
> ...but a simple test file fails to compile. It generates no pdf output and a missfont.log with the contents:
> mktexpk --mfmode / --bdpi 600 --mag 1+57/600 --dpi 657 mt2mit
> The console contains the following:
> [...]
> [1{/Users/themis/Library/texlive/2012/texmf-var/fonts/map/pdftex/updmap/pdftex.
> map}] (./test.aux) ){/usr/local/texlive/2012/texmf-dist/fonts/enc/dvips/base/8r
> .enc}
> kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+57/600 --dpi 657 mt2mit
> mktexpk: don't know how to create bitmap font for mt2mit.
> mktexpk: perhaps mt2mit is missing from the map file.
> kpathsea: Appending font creation commands to missfont.log.
> !pdfTeX error: /usr/texbin/pdflatex (file mt2mit): Font mt2mit at 657 not found
> ==> Fatal error occurred, no output PDF file produced!
> Themis


Where did you put the mtpro2.map file? Does the updmap.cfg end with a blank line? Did you ever run `sudo updmap`? Please remove ~/Library/texlive/2012 folder and retry


without any `sudo`.

Please let me know if this doesn't work.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list