[OS X TeX] Activating mtpro2 in Texlive 2012

Themis Matsoukas tmatsoukas at me.com
Tue Sep 4 20:52:28 CEST 2012

I installed TeX Live 2012 through the mactex package but I am unable to activate mtpro2 (PC TEX MathPro Lite), which worked in the previous installation. I am following Herb's instructions:

1. The fonts are installed in my personal tree: /Users/themis/Library/texmf/...

2. I created the file /Users/themis/Library/texmf/web2c/updmap.cfg with contents:

#! Map belleek.map
Map mtpro2.map

3. I run updmap on the terminal.

...but a simple test file fails to compile. It generates no pdf output and a missfont.log with the contents:

mktexpk --mfmode / --bdpi 600 --mag 1+57/600 --dpi 657 mt2mit

The console contains the following:
map}] (./test.aux) ){/usr/local/texlive/2012/texmf-dist/fonts/enc/dvips/base/8r
kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+57/600 --dpi 657 mt2mit
mktexpk: don't know how to create bitmap font for mt2mit.
mktexpk: perhaps mt2mit is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.

!pdfTeX error: /usr/texbin/pdflatex (file mt2mit): Font mt2mit at 657 not found

 ==> Fatal error occurred, no output PDF file produced!


More information about the macostex-archives mailing list