[OS X TeX] simpdftex can't find font, but pdflatex can

Nathan Sanders professor.sanders at gmail.com
Fri Mar 2 02:45:42 CET 2012

On Mar 1, 2012, at 8:32 PM, Herbert Schulz wrote:

> On Mar 1, 2012, at 7:25 PM, Nathan Sanders wrote:
>> Ah, no, there is no option, but the documentation does say that I can edit the map file, replacing .tff with .pfb.  So, I just did that, and then texhash and updmap-sys.... but I still get the same error (/usr/texbin/dvips: ! Couldn't find header file: TengwarQuenya.ttf).  How do I get the psfonts.map updated correctly?  It has a scary warning at the top not to edit it manually!  :-)
>> Thanks, we're much closer than I got by myself!
> You may have to disable the map and then re-enable the map for the changes to take place.

Aha, okay, that changed things.  The new error is:

/usr/texbin/dvips: ! Couldn't find font file TengwarQuenya.pfb

And lo and behold, it doesn't exist.  The pfb files I do have are: QUENCAP1.PFB, QUENCAP2.PFB, QUENYA.PFB, QUENYAA.PFB

I have a hunch it's not as simple as renaming one of these to TengwarQuenya.pfb!

The documentation says I can use ttf2pl to generate pfb files, but that's not on my system.  It says I can use fontforge, which I'll try.

In the meantime, if any of you know the best way to generate the files I need, pointers would be appreciated!

> The only way I can understand that it worked ``last year'' is that there was a map file with the pfb's in the older distribution that happened to get read before your ttf map. Even that is rather far-fetched.

Yeah, I really don't know.  It worked.  Maybe I was using pdflatex at the time without realizing it; it could have been during one of my attempts to switch over.


Nathan Sanders
Department of Linguistics
Swarthmore College

More information about the macostex-archives mailing list