[tex-live] [OS X TeX] texlive.infra: "local version is newer"

Herbert Schulz herbs at wideopenwest.com
Sat Jun 12 00:04:37 CEST 2010

On Jun 11, 2010, at 4:48 PM, Justin C. Walker wrote:

> On Jun 7, 2010, at 08:15 , Victor Ivrii wrote:
>> On Mon, Jun 7, 2010 at 11:04 AM, Patrick Wambacq
>> <Patrick.Wambacq at esat.kuleuven.be> wrote:
>>> I am seeing the following message in TLU:
>>> texlive.infra
>>> status: local version is newer
>>> installed: 18166
>>> remote: 17958
>>> when trying to update. This is the output of tlmgr --version:
> [snip]
>> This question could be answered ONLY by TL team and I forward your
>> question there
>> My own versions of texlive.infra coincides with remote and tlmgr
>> --version returns 17811
>> It looks like your local version numbers are not right but they are in
>> TL2009 rather then TL2010 range
> I think I've been bitten by a version of this:
> TLU (Mac OS X) tells me, for example, that 'a2ping.universal-darwin' has local version 16044, and remote version 9317.  I have a whole batch of similar entries and no others (i.e., all either match or are newer on the local system).
> When I run the update, each of these generates the message 'unhandled status "r "' (from tlu_ipctask).
> Things were working well until I tried an update sometime yesterday evening (or early this AM, PST).
> Something going on at the factory?  I've tried updating several times, all with the same results.
> Justin


I put Victor's commands into a shell script to run from any directory where you have write permissions (it saves the files names in a file). You'll have to give and admin password since it writes to the TeX Distribution bin directories. I tried out both 32bit and 64bit binaries and everything seems to work fine.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: update.sh.zip
Type: application/zip
Size: 650 bytes
Desc: not available
URL: <http://tug.org/pipermail/macostex-archives/attachments/20100611/1dba047a/attachment.zip>
-------------- next part --------------

I first ran TLU and had it update everything it could (there were some real updates too) and it skips over those. That leaves only those to be ``reinstalled''. Then I ran the script and gave my admin password.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

More information about the macostex-archives mailing list