[OS X TeX] BibTeX-Problem on Mac: couldn't open style file/ couldn't open database file

Justin C. Walker justin at mac.com
Thu Oct 30 01:46:46 CET 2008

On Oct 29, 2008, at 17:14 , Matthias Geissbuehler wrote:

>>> I have them all inside a folder:
>>> /Users/myUserName/downloads/test/
>> It might work when you move (drag) the test directory (folder) into /
>> Users/myUserName/Library/texmf.
> no it still doesn't work... same error:  :-(

A really stupid question, just to clear something up: in what  
directory did you put the .bst file?

It seems that kpsewhich (and presumably the TeX commands in general)  
are kind of persnickity about where they expect to find specific kinds  
of files.

If I put "fred.bst" into my local texmf tree (~/Library/texmf), I get  
the following from kpsewhich

~/Library/texmf/bibtex      Not Found
~/Library/texmf/bibtex/bst  Found
~/Library/texmf/bibtex/bib  Not Found

If I put "fred" (no ".bst") in either of those locations, it is not  



Justin C. Walker, Curmudgeon at Large
Institute for the Enhancement of the Director's Income
Nobody knows the trouble I've been

More information about the macostex-archives mailing list