[OS X TeX] BibTeX-Problem on Mac: couldn't open style file/ couldn't open database file

Matthias Geissbuehler matthias.geissbuehler at epfl.ch
Wed Oct 29 19:17:25 CET 2008

Hello everyone,

I'm a rather long term user of Latex on Mac OS X but today I ran into  
a problem that I couldn't figure out how to resolve this.
In short the problem is that I can't get my BibTeX to work anymore.

Here is what happens:

1) To limit possible reasons I went for the simplest example using  
a .bib file. I found one here:
http://shelah.logic.at/eindex.html (three files)

2) I ran Latex (2x) over the file and then Bibtex (1x) (from within  
TeXShop). Here is the output that I get:
This is BibTeX, Version 0.99c (Web2C 7.5.7)
The top-level auxiliary file: lpaper.aux
I couldn't open style file unsrt.bst
---line 7 of file lpaper.aux
  : \bibstyle{unsrt
  :                }
I'm skipping whatever remains of this command
I couldn't open database file listb.bib
---line 8 of file lpaper.aux
  : \bibdata{listb
  :               ,mybib}
I'm skipping whatever remains of this command
I found no database files---while reading file lpaper.aux
I found no style file---while reading file lpaper.aux
(There were 4 error messages)

3) To check if it has something to do with my configuration, I asked  
my brother to compile the same three files for me on his Mac (same  
distribution) and it did work without problems! (with exactly the same  

4) My first attempt to resolve this was by just re-installing the  
newest MacTex distribution: TeXLive-2008. -> I did so, and I still get  
the same error message.

I'm certain that my distribution did work before (with BibTex as  
well). The only thing I can think of for the moment, is that I  
installed LyX for Mac recently (in order to help out a friend how to  
use it...).

Any help with this would be really appreciated!

Thanks a lot!


More information about the macostex-archives mailing list