[OS X TeX] novice query concerning international characters

cfrees at imapmail.org cfrees at imapmail.org
Thu Oct 9 23:47:05 CEST 2008

Thanks very much. I know I tried that at one point but didn't really
know what should work so tried a bunch of things. My minimal test now
works, as you say. I apparently didn't try the right combination with a
sufficiently minimal test.

Now I know what should work, I should be able to figure out why my
non-minimal document is still protesting. :)

Much appreciated,

On Thu 9th Oct, 2008 at 23:13, Maarten Sneep seems to have written:

> Hi,
> This is actually how I discovered the solution, so this is something you may 
> want to refer to for unrelated problems.
> On 9 okt 2008, at 22:52, Dr. Clea F. Rees wrote:
>> 	\documentclass[11pt,welsh]{article}
>> 	\usepackage{babel}
>> 	\usepackage[utf8]{inputenc}
>> with or without
>> 	\usepackage{lmodern}
>> produces the same results.
>> I use the Welsh keyboard for input which makes it easy to type
>> characters with circumflexes. That is, the 7 vowels: a, e, i, o, u, w,
>> y. But using a different keyboard (e.g. US) produces the same results.
>> Things work fine for a, e, i and u. Not so fine for the others. w and y
>> are not typeset at all if typed with a circumflex. (Presumbably because
>> OT1, T1 are missing slots for w and y circumflex.) I also get console 
>> errors about o circumflex and I'm not sure why:
>> 	! Package inputenc Error: Keyboard character used is undefined
>> 	(inputenc)                in inputencoding `utf8'.
>> 	See the inputenc package documentation for explanation.
>> The output looks fine for o with a circumflex, but every occurrence
>> triggers this error.
> First check: Latin Modern has the characters ? (LATIN SMALL LETTER Y WITH 
> CIRCUMFLEX, unicode 0177, utf-8 C5B7) and ? (LATIN SMALL LETTER W WITH 
> CIRCUMFLEX, unicode 0175, utf-8 C5B5) in all shape variants. Sorry for 
> shouting, this is how the character panel names them.
> So it should be possible to use these characters, but perhaps the mapping is 
> incorrect. This is not something I know a lot about. Possible solutions:
> - use XeTeX, or more precisely: xelatex. This path is unicode/utf-8 from 
> start to finish, so there is not a lot that can mess things up.
> - Access the characters directly. In trying to figure out how to do this, I 
> used 'texdoc inputenc'. This opens the documentation for inputenc, but this 
> only lists 8-bit encodings, not utf8. Then I recalled that the ucs package is 
> a possibility. 'texdoc ucs' This opens a text file in the terminal, and in it 
> I find:
> Question: When I try to activate options in \usepackage[...]{ucs},
> LaTeX complains about an option clash.
> Answer: ucs.sty probably already got loaded via
> \usepackage[utf8x]{inputenc}. Try loading ucs.sty first or set the
> options with \SetUnicodeOption.
> Then I recalled that loading the utf8 encoding through ucs, requires 
> \usepackage[utf8x]{inputenc}.
> Minimal test file:
> \documentclass[11pt,welsh]{article}
> \usepackage{babel}
> \usepackage[utf8x]{inputenc}
> \usepackage{lmodern}
> \begin{document}
> ??
> \end{document}
> This gives the desired results.
> Maarten

More information about the macostex-archives mailing list