[OS X TeX] cmss vs. \sfdefault font question

Gary L. Gray gray at engr.psu.edu
Tue Aug 8 03:37:38 CEST 2006

On Aug 7, 2006, at 7:20 PM, Herbert Schulz wrote:

> On Aug 7, 2006, at 6:09 PM, Gary L. Gray wrote:
>> Something came up today that has me perplexed. I have a document  
>> that I created in January that uses:
>> \renewcommand{\familydefault}{cmss}
>> to make everything sans serif. When typeset in January, it looked  
>> great and all nice Postscript fonts were used. I just tried  
>> typesetting it and it took forever as mf had to create all the  
>> fonts. When it was done, it looked terrible (all bitmapped fonts).  
>> I did a quick search on the list and found this command:
>> \renewcommand{\familydefault}{\sfdefault}
>> which worked perfectly.
>> My question is, what in LaTeX has changed? Why did cmss work 7  
>> months ago and why does it not work now?
>> Thank you.
>> -- Gary
> Howdy,
> Not sure if I'm barking up the wrong tree here but what does \the 
> \sfdefault (is that the correct way of doing it?) return.

I get an error when I try that.

> Maybe looking at the console output will help too; what fonts are  
> included when it works and when it doesn't work?

It doesn't help me. :-)

> Have you updated the system?

I have the most recent TeX installation as well as the LaTeX updater.

> Using T1 font encoding?

I am. I load:


-- Gary
------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list