[OS X TeX] cmss vs. \sfdefault font question

Bruno Voisin bvoisin at mac.com
Tue Aug 8 01:25:58 CEST 2006

Le 8 août 06 à 01:09, Gary L. Gray a écrit :

> Something came up today that has me perplexed. I have a document  
> that I created in January that uses:
> \renewcommand{\familydefault}{cmss}
> to make everything sans serif. When typeset in January, it looked  
> great and all nice Postscript fonts were used. I just tried  
> typesetting it and it took forever as mf had to create all the  
> fonts. When it was done, it looked terrible (all bitmapped fonts).  
> I did a quick search on the list and found this command:
> \renewcommand{\familydefault}{\sfdefault}
> which worked perfectly.
> My question is, what in LaTeX has changed? Why did cmss work 7  
> months ago and why does it not work now?

Hi Gary,

Is this all on the same computer? IIRC you got a MacBook Pro earlier  
this year, is it possible that cmss was working on your former  
computer and is no longer working on your current computer? If so,  
that would be a configuration problem.

Both commands yield the same output on my setup. I'm not sure what's  
the TeX code to get the definition of a command written to the log  
(and I've no TeXbook around), could it be \the\sfdefault? What does  
it yield for you? Also, doesn't (for example) /usr/local/teTeX/share/ 
texmf.local/fonts/map/pdftex/updmap/pdftex.map contain lines like:

cmss10 CMSS10 <cmss10.pfb

As just pointed out by Herb Schultz as I'm writing this, it might  
also be a matter of T1 vs. OT1 vs. LY1 encodings, of the presence or  
not of CM-Super, of use or not of the lmodern package, etc.

Bruno------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list