[OS X TeX] TeXShop & dvi files

Bruno Voisin bvoisin at mac.com
Thu Sep 22 11:42:43 CEST 2005

Le 22 sept. 05 à 11:26, Morten Poulsen a écrit :

> I recently switched from fink to using my own build of teTeX and
> ghostscript. I adjusted the paths in the engine preferences.  
> Everything
> seemed to work as usual, until I tried to open a dvi file (which I  
> can read
> and write) in TeXShop - nothing happened. TeXShop used to open dvi  
> files
> perfectly. I'm using TeXShop version 2.03.
> Is it my own build of teTeX and/or ghostscript that are causing  
> problems?
> I tried to switch distiller to Apple's, no difference. Is there a  
> log somewhere
> that might tell me what TeXShop is doing? Any ideas?

Previously TeXShop relied, for the DVI -> PDF conversion, on the  
scripts altpdftex and/or alpdftex, versions of which were included in  
the application bundle:


I'm not quite sure which of the bundled altpdflatex, or of the script  
altpdflatexc.bxx setting the paths to /usr/local/teTeX/bin/powerpc- 
apple-darwin-current and /usr/local/bin then calling altpdflatex  
there, was used.

In any case, now the scripts altpdflatex and altpdftex have been  
deprecated and have been made aliases to /usr/local/teTeX/bin/powerpc- 
apple-darwin-current/simpdftex, which is the script TeXShop is now  
using (as specified in its Engine Prefs). And it seems TeXShop  
includes no bundled simpdftex.

I suspect your problem comes from there: not having this script in  
your build of teTeX.

Hope this helps,

Bruno Voisin------------------------- Info --------------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
          & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Archive: http://tug.org/pipermail/macostex-archives/

More information about the macostex-archives mailing list