[OS X TeX] documentclass undefined

Vince Filby vfilby at gmail.com
Fri Aug 26 21:08:32 CEST 2005

Woo, i think we are making progress.  Let me report my findings here for you:

 vfilby% ls -l `which latex` 
lrwxr-xr-x   1 root  wheel  7 Aug 26 10:58
/usr/local/teTeX/bin/powerpc-apple-darwin-current/latex -> pdfetex

in fact it looks like all the programs are symlinked to pdfetex.  The
path's are all correct, when I specify the full path I still get the
same result.   Specifying -progname=latex caused my test.tex file to
compile with out error.

 vfilby% pdfetex -progname=latex test
This is pdfeTeX, Version 3.141592-1.20a-2.2 (Web2C 7.5.3)
output format initialized to DVI
entering extended mode
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, d
utch, italian, norsk, portuges, spanish, swedish, nohyphenation, loaded.
Document Class: article 2004/02/16 v1.4f Standard LaTeX document class
(/usr/local/teTeX/share/texmf.tetex/tex/latex/base/size10.clo)) (./test.aux)
[1] (./test.aux) )
Output written on test.dvi (1 page, 232 bytes).
Transcript written on test.log.    

Is there a way to get latex to always do the -progname=latex or should
I just write a short shell script?


--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the macostex-archives mailing list