[OS X TeX] XeTeX 0.86 & TexShop 1.35e typesets nonsense

Jonathan Kew jonathan_kew at sil.org
Thu Sep 9 21:42:11 CEST 2004

On 9 Sep 2004, at 7:20 pm, Mika Luoma-aho wrote:

> I installed XeTeX 0.86 on teTex on my G4 Panther, and the latest 
> version of TexShop (1.35e). In TexShop preferences, I added misc -> 
> personal script -> xelatex and changed typesetting -> default command 
> -> command listed below: xelatex. I saved my .tex files to unicode-8.
> As a result, I am typesetting nonsense: the documents look all wrong, 
> with odd graphics and no text anywhere to be seen. I hope I could 
> describe this better somehow.. there are no words..
> I tried changing prefs back to tex-like in random desperation, but 
> with disappointing results: the engine refuses to compile anything and 
> prompts an error with every command. Tried re-installing TexShop and 
> doing it all over again. Alas, all the trauma all over again. Now I am 
> about to panic. Please tell me there is a simple solution to all this. 
> Even small favours will do.

Hello Mika -

Sorry to hear of your trauma! I'm not clear just what is going on; 
maybe a few questions will help us figure things out. Have you tried 
some of the XeTeX sample files, and do they work? Have you tried 
typesetting from the command line in Terminal, and what happens then?

When you say "I saved my .tex files to unicode-8", what procedure do 
you mean that you did? It sounds as though the character encoding may 
have been changed incorrectly in some way; if you wish, send me an 
example file (off-list) and I'll take a look.


--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the macostex-archives mailing list