[OS X TeX] What Happened to Latin Modern?

Gerben Wierda Gerben.Wierda at rna.nl
Mon Oct 25 12:44:54 CEST 2004

> Hello all,
> After installing TL2004 on saturday, all went well.
> But suddenly, problems appeared (at midnight :-) ) when I had to add a
> MetaPost figure to my document.
> Symptom 1:
> a TeXShop crash (which I never experienced until now) due to (so I
> think) to
> 	\DeclareGraphicsRule{*}{mps}{*}{}
> because including the graphic after conversion to pdf worked fine;
> Symptom 2:
> I added labels to my graphic - which caused GhostScript to terminate
> with an error
> 	Error: /undefined in cmmi7
>   when called by epstopdf.

This is something I would like to have stuff at my site so I can reproduce
and find out what needs to be fixed. Is there a small setup that I can

> (That seems to explain the TeXShop crash: it cannot handle error
> messages from GhostScript.)
> I tried:
>> Please re-run configure for your i-Package and (when asked to) update
>> first.
>> It is possible that the fix solves your problem.
>> G
> which simply annihilated my LatinModern setup:
> 	Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600
> cork-lmri9
> 	mktexpk: don't know how to create bitmap font for cork-lmri9.
> 	kpathsea: Appending font creation commands to missfont.log.
> I tried a reinstall - to no avail.

Could you send me a report from i-Installer of the reinstall off list? I
am not at my desktop right now and it is possible I made a mistake in the
configuration such that LM from teTeX 3 is not configured, but I need to
see the output from your install run.

> Switching to cm-super restored my document.
> I'm confused as this is the first time I experience a configuration
> problem with my TeX installation.

Well, the whole public release has somewhat been premature with respect to
my original plan. But I'll work as hard as possible to iron any glitches

If you install TL2004 and you do not have Latin Modern, it is likely that
configuration for some reason skips the LM config.

Of course, temporarily, you can go back to the TL2003 setup and install
Latin Modern there.

Before you do that, try this in a Terminal window

sudo updmap --nomkmap --enable Map cork-lm.map
sudo updmap --nomkmap --enable Map lm.map
sudo updmap --nomkmap --enable Map qx-lm.map
sudo updmap --nomkmap --enable Map texnansi-lm.map
sudo updmap --nomkmap --enable Map ts1-lm.map
sudo updmap

Which is what configure of the i-Package *should* do. LM should work after
that. Maybe there is some reason why updmap crashes and the map files are
not generated.



--------------------- Info ---------------------
Mac-TeX Website: http://www.esm.psu.edu/mac-tex/
           & FAQ: http://latex.yauh.de/faq/
TeX FAQ: http://www.tex.ac.uk/faq
List Post: <mailto:MacOSX-TeX at email.esm.psu.edu>

More information about the macostex-archives mailing list