[OS X TeX] (Mis)adventures of a TIC

Bruno Voisin bvoisin at mac.com
Fri Jun 4 23:16:17 CEST 2004

Le 4 juin 04, à 22:18, Alain Schremmer a écrit :

>  Then, before I had time re-installing it following Voisin's 
> instructions, I started getting the following message when wanting to 
> typeset
> Can't find required tool
>  /usr/local/teTeX/bin/powerpc-apple-darwin-current/xelatex does not 
> exist.  Is one of the tool paths configured incorrectly?
>  [...]
>  Then, I remembered that somewhere along the line before the not so 
> clean install, I had i-installed the XeTeX from sil.org thinking I had 
> to. (Why I thought I had to now beats me.)
>  So, I went back to TeXshop preferences and, sure enough, I found 
> something about Xelatex so I reset the Default values everywhere.

Most likely you had set "xetex" as your TeX personal script, and 
"xelatex" as LaTeX personal script, in Preferences/Script. This is 
perfectly right, and part of a successful XeTeX install. But...

Then the above error message indicates that you were running XeLaTeX 
without knowing it (Mr Jourdain ?), most likely because you had set 
"Personal Script" as your default script, in Preferences/Typeset. 
Hence, every time you press LaTeX, XeLaTeX is run, and every time you 
press TeX, XeTeX is run. In other terms, because Personal Script was 
your default script, XeTeX had become your default TeX.

Cure: just set pdfTeX or TeX + Ghostscript as personal script. You may 
then erase or not xetex and xelatex as your personal scripts.

>  So, since I knew it was real easy, I decided just to do a clean 
> install. I trashed any folder that had tex in it and emptied the 
> trash. Then I installed TeXshop following the instructions on the 
> site, creating folders as needed. It felt real good.
>  Then, I started TeXshop and then, not quite unexpectedly, I noticed 
> that it still had my Open Recent files. Must be some preference file 
> buried somewhere. Not to worry.
>  Opened last file I worked on. Looks the way I left it.
>  Tried to typeset it.
>  Same message as above!!!

Quite normal: erasing your whole TeXShop/teTeX install just because of 
that problem was overkill. The TeXShop prefs are actually stored in 
~/Library/Preferences/TeXShop.plist. For example, mine has:


and Personal Script as the default script corresponds to:


Hope this helps,

Bruno Voisin
Post: <mailto:MacOSX-TeX at email.esm.psu.edu>
Please see <http://www.esm.psu.edu/mac-tex/> for list
guidelines, information, and LaTeX/TeX resources.

More information about the macostex-archives mailing list