[Mac OS X TeX] custom format files?

Joachim Kock kock at math.unice.fr
Thu Feb 21 02:48:08 CET 2002


I upgraded to a recent version of teTeX (20020129) and I have a
problem with custom formats (which I didn't have with my old
installation (20010417)).  The problem seems to be related to
a change in how format files are found...

I would be very happy if somebody could help me, and I imagine
the advice would benefit other users as well...

My init file (called hitex.ini) is simply this:

   \usepackage{amsmath} \usepackage{amssymb} \usepackage{latexsym}
   \input{diagrams} \usepackage{curves}
   \usepackage{meu} \input{eng-sec}

(all packages of which work well in the new teTeX, when
loaded in a standard latex file).

So I do

[prompt]: initex
**&latex hitex.ini\dump
[prompt]: mv hitex.fmt ~/Library/texmf/web2c/hitex.fmt
[prompt]: ln -s /usr/local/teTeX/bin/powerpc-apple-darwin-current/latex

Then open a new terminal window, (and I also tried texhash).

[prompt]: hitex foo
calls latex, but loading standard latex.fmt instead of loading
hitex.fmt.  (It is not the case that for some reason hitex.fmt is
identical to latex.fmt: I have tried to put an empty file in place of
hitex.fmt, and nobody complains about that, so I conclude that the
file is never read...).  Somehow it seems that the mechanism which
determines the format from the name of the command does not work.

Let me say again that all this worked fine with my old teTeX
installation.   (For this reason, I am not embarrassed to ask for help.)

On the other hand, I also had a problem with the old installation:
Compiling a pdftex format called hiptex (from the same source as
above), doing

[prompt]: pdfinitex
**&pdflatex hitex.ini\dump
[prompt]: mv hitex.fmt ~/Library/texmf/web2c/hiptex.fmt
[prompt]: ln -s /usr/local/teTeX/bin/powerpc-apple-darwin-current/pdflatex

when trying to run it I got this error:

[prompt]: hiptex foo
This is pdfTeX, Version 3.14159-14h-released-20010417 (Web2C
Error: hiptex (file pdftex.cfg): cannot open config file

Now doing exactly the same in the new teTeX installation doesn't give this
error --- for the same reason as for latex: the hiptex.fmt file is never
read, so instead of the pdftex.cfg error, I now get the error caused by
missing documentclass and all that, due to missing my preamble...

Although the pdftex.cfg problem has disappeared for the moment, I
would also be glad if somebody could help me with that.  Because
either the fmt problem will be solved and then I expect the cfg problem
to reappear, or it is not solved and then I will revert to my old
installation where the cfg problem is...

Thanks in advance for any help,

Joachim KOCK
Laboratoire de Mathématiques J.A.Dieudonné    Tél.  +33
Université de Nice Sophia-Antipolis           Fax   +33
Parc Valrose - 06108 Nice cédex 2 - FRANCE    Mél.  kock at math.unice.fr

To UNSUBSCRIBE, send email to <info at email.esm.psu.edu> with
"unsubscribe macosx-tex" (no quotes) in the body.
For additional HELP, send email to <info at email.esm.psu.edu> with
"help" (no quotes) in the body.
This list is not moderated, and I am not responsible for
messages posted by third parties.

More information about the macostex-archives mailing list