[luatex] Problems with LuaTeX 1.0.8

Henri Menke henrimenke at gmail.com
Sat Feb 9 23:53:15 CET 2019

I tried to construct a minimal example in plain TeX using luaotfload but
could not reproduce your problem (MWE below).

I have never used Speedata, so I have no idea whether it even uses
luaotfload.  Another thing to keep in mind is that with LuaTeX 1.08, the
Lua version was upgraded from 5.2 to 5.3, introducing integer arithmetic
and a different random number generator.  It well be that what you see
are rounding errors.


\input luaotfload.sty

\font\1="file:texgyreheros-regular.otf:mode=node;" at 12pt


\1 At mid-century, Chicago was the “City of the Big Shoulders,” the
mightiest industrial city of them all. Thirty years later, in the
‘80s, it was “Beirut by the Lake,” a troubled metropolis caught in
economic decay and torn by racial politics. Along the way it’s been
the “Second City” or the “City on the Make” or, as the first Mayor
Daley had it, “The City That Works,” a name that stuck even at a time
when it seemed the city stopped working.


On 2/10/19 12:53 AM, Patrick Gundlach wrote:
> Hi all,
> my software uses LuaTeX 1.0.7 and now I have tried out 1.0.9. To my surprise some documents are formatted differently.
> The LuaTeX version which breaks my things is 1.0.8 (svn commit id 6909). Now this is a huge commit and I have no idea where to look for changes that might apply to my document.
> Is there a more detailed commit history to look for the exact changes so I can track down my problem?
> For information: two different PDFs are uploaded to:
> https://github.com/speedata/publisher/issues/223
> Patrick

More information about the luatex mailing list