[luatex] Using a Lua C .so module with LuaLaTeX

luigi scarso luigi.scarso at gmail.com
Tue Nov 17 09:12:15 CET 2015

On Tue, Nov 17, 2015 at 8:55 AM, Deepak Jois <deepak.jois at gmail.com> wrote:

> I am still digging into this…
> On Mon, Nov 16, 2015 at 11:21 PM, Deepak Jois <deepak.jois at gmail.com>
> wrote:
> > Like I said before, when I build luatex with --nostrip, it works fine.
> > Has this ever been enabled by default?
> >
> I ran into this mailing thread on tlbuild about stripping luatex binary
> * Part 1: http://tug.org/pipermail/tlbuild/2011q2/001842.html
> * Part 2: http://tug.org/pipermail/tlbuild/2011q1/001832.html
> There is also this bug: http://tracker.luatex.org/view.php?id=555
> The mailing list discussion is inconclusive. The bug report says that
> “seems to be resolved by --nostrip flag”, but it looks like the luatex
> binary in TeXLive as well as in trunk is stripped.
yes, could be.

> It is still not clear to me if loading .so libraries is supported on OS X.
> Anyway, as an alternative I can use my own luatex binary compiled with
> --nostrip. Could somebody tell me how I go about using it with a .tex
> file? Do I need some sort of alternative TeXLive-like environment? How
> do I go about building that?
> Deepak
> No, the texlive is ok, but unfortunately the 0.85 breaks compatibility.
So you should wait until things are updated, or just use your compiled
The current TL uses 0.80.0, and you can find the source at

You should have no problem to compile it and replace the standard binary of
(and rebuild the formats, to be sure).

If it works for you , can you try
strip -u -r luatex
as reported by Tantau at
http://tracker.luatex.org/view.php?id=555 ?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/luatex/attachments/20151117/8326860f/attachment.html>

More information about the luatex mailing list