[luatex] Using a Lua C .so module with LuaLaTeX

Deepak Jois deepak.jois at gmail.com
Tue Nov 17 08:55:47 CET 2015

I am still digging into this…

On Mon, Nov 16, 2015 at 11:21 PM, Deepak Jois <deepak.jois at gmail.com> wrote:

> Like I said before, when I build luatex with --nostrip, it works fine.
> Has this ever been enabled by default?

I ran into this mailing thread on tlbuild about stripping luatex binary

* Part 1: http://tug.org/pipermail/tlbuild/2011q2/001842.html
* Part 2: http://tug.org/pipermail/tlbuild/2011q1/001832.html

There is also this bug: http://tracker.luatex.org/view.php?id=555

The mailing list discussion is inconclusive. The bug report says that
“seems to be resolved by --nostrip flag”, but it looks like the luatex
binary in TeXLive as well as in trunk is stripped.

It is still not clear to me if loading .so libraries is supported on OS X.

Anyway, as an alternative I can use my own luatex binary compiled with
--nostrip. Could somebody tell me how I go about using it with a .tex
file? Do I need some sort of alternative TeXLive-like environment? How
do I go about building that?


More information about the luatex mailing list