[luatex] Newbie question: how do create (and use) a lualatex.fmt with luatex-0.79.1?

Eduardo Ochs eduardoochs at gmail.com
Fri May 2 19:55:23 CEST 2014

On Thu, May 1, 2014 at 8:20 PM, Mojca Miklavec
<mojca.miklavec.lists at gmail.com> wrote:
> Yes, this is the supposed way to build luatex (other than fetching it
> from svn tag or TeX Live). But you are "not supposed" to build version
> 0.79.0. Version 0.79.1 has been released precisely to solve the
> problems you are experiencing.

I have now been able to compile luatex-0.79.1 at my Debian box, but I
can't figure out how to make it run as lualatex... in other words, I
am stuck at trying to translate this paragraph of the "INSTALL" file,

  Post-compilation installation should be a simple matter
  of copying the executable to a normal place for web2c
  binaries and generating the desired formats.

into executable commands - sorry! And: help, please! 8-(

Here's my understanding of what should happen after the "./build.sh".
I now have a binary at


It is a kind of an "initex", so I need to use it to generate a
"lualatex.fmt". I run

  cd /tmp/
  ~/bigsrc/luatex-beta-0.79.1/build/texk/web2c/luatex '&lualatex'  2>&1 | tee o

and then the log file (/tmp/o) says that it read the "lualatex.ini"
and friends from the current texlive installation, and created a .fmt
and a .log file at:


Now how do I run the luatex binary in non-initex mode, and make it use
the newly-created "lualatex.fmt" instead of the one from texlive, that
is here?


That ought to be trivial - I am probably overlooking something in the

  Thanks in advance,
    Eduardo Ochs
    eduardoochs at gmail.com

More information about the luatex mailing list