[luatex] Newbie question: how do create (and use) a lualatex.fmt with luatex-0.79.1?

Mojca Miklavec mojca.miklavec.lists at gmail.com
Mon May 5 23:51:03 CEST 2014

On Fri, May 2, 2014 at 7:55 PM, Eduardo Ochs wrote:
> On Thu, May 1, 2014 at 8:20 PM, Mojca Miklavec wrote:
>> Yes, this is the supposed way to build luatex (other than fetching it
>> from svn tag or TeX Live). But you are "not supposed" to build version
>> 0.79.0. Version 0.79.1 has been released precisely to solve the
>> problems you are experiencing.
> I have now been able to compile luatex-0.79.1 at my Debian box, but I
> can't figure out how to make it run as lualatex...

The easiest way by far is to install TeX Live 2014 from one of the
tlpretest mirrors.


And from what I understood the TL 2014 testing packages for Debian are
ready as well.

The second-easiest thing is to replace the existing luatex binary and
run "fmtutil --all" or "sudo fmtutil-sys --all" (or "--byfmt lualatex"
or something similar) to generate the formats for you.

Please keep in mind that once you run those commands, you might need
to deleted the user-generated formats when you upgrade TeX Live.

> in other words, I
> am stuck at trying to translate this paragraph of the "INSTALL" file,
>   Post-compilation installation should be a simple matter
>   of copying the executable to a normal place for web2c
>   binaries and generating the desired formats.
> into executable commands - sorry! And: help, please! 8-(
> Here's my understanding of what should happen after the "./build.sh".
> I now have a binary at
>   ~/bigsrc/luatex-beta-0.79.1/build/texk/web2c/luatex
> It is a kind of an "initex", so I need to use it to generate a
> "lualatex.fmt". I run
>   cd /tmp/
>   ~/bigsrc/luatex-beta-0.79.1/build/texk/web2c/luatex '&lualatex'  2>&1 | tee o
> and then the log file (/tmp/o) says that it read the "lualatex.ini"
> and friends from the current texlive installation, and created a .fmt
> and a .log file at:
>   ~/.texmf-var/web2c/luatex/lualatex.fmt
>   ~/.texmf-var/web2c/luatex/lualatex.log
> Now how do I run the luatex binary in non-initex mode, and make it use
> the newly-created "lualatex.fmt" instead of the one from texlive, that
> is here?
>   /var/lib/texmf/web2c/luatex/lualatex.fmt
> That ought to be trivial - I am probably overlooking something in the
> docs...

I'm not 100% sure if that applies in your case, but if you place the
luatex binary at some weird location, you might need to redefine a
bunch of configuration variables to allow luatex to properly find the
relevant files. The search is always done relative to the original
binary. Unless you know what you are doing ... it could get tricky and
it could depend on how exactly you installed TL. And if you took
Debian's TL, there is a fair chance that texmf.cnf uses different
variables than your self-compiled binary. You can take a look at all
instances of texmf.cnf on your machine.


More information about the luatex mailing list