[luatex] mkluatexfontdb devours memory

Ismo Toijala ismo.toijala at gmail.com
Sat May 11 15:01:55 CEST 2013

>> I also run Arch Linux and ran into this problem when testing svn
>> versions of LuaTeX. Are you sure that you copied the binary into
>> /usr/bin?
> no, it is at
> /home/texlive2013/bin/x86_64-linux/luatex
> where all other binaries are. This works fine for the old luatex, also the
> PATH is set to this place.

You're right, I realized after posting that you are not using the Arch packages.

My setup is very similar, except my TeXLive is in ~/.texlive/2013

> Well, I just replaced the working luatex binary by the one I built. If it
> worked for the the old one, it should be fine for the new one, too, no?

I just tested this myself and ran into exactly the same problem.
I compiled LuaTeX from the newest svn sources and copied it to bin/x86_64-linux.

> It's called texmf.cnf here, but I guess that was a typo. What exactly should
> I adapt here?

Yes, a typo.

I tried changing TEXMFROOT to an absolute path. It still doesnt't work.

If I don't copy the binary to the right place, it complains that it
cannot find temf.cnf. This means that the file is found when the
binary in in the right place.


More information about the luatex mailing list