[luatex] METAPOST labels in Lualatex: illegal unit of measure

Jean J2N-FORGET at orange.fr
Mon May 6 06:56:40 CEST 2013

Le vendredi 03 mai 2013 à 13:30 +0900, Dohyun Kim a écrit :
> 2013/5/3 Dohyun Kim <nomosnomos at gmail.com>:
> >
> > BTW, without \usepackage{fontspec}, I get "undefined control sequence"
> > error at \pdfstrcmp. I haven't noticed that before, as I always loaded
> > fontspec package. However, fontspec is a too heavy a package for
> > \pdfstrcmp command only. Could anybody tell me what package is
> > suitable for this purpose? I tried \usepackage{pdftexcmds}, but of no
> > use.
> OK. According to the manual, pdftexcmds package provides not
> \pdfstrcmp, but \pdf at strcmp instead. Therefore luatexko-mplib.sty
> should be patched as follows:
> 10a11
> >   \input pdftexcmds.sty
> 13a15
> >   \RequirePackage{pdftexcmds}
> 61c63
> <   \ifnum\pdfstrcmp{#1}{mplibcode}=\z@
> ---
> >   \ifnum\pdf at strcmp{#1}{mplibcode}=\z@
> Then no need to load fontspec.  Élle, please apply this patch as well
> when you import luatexko-mplib to luamplib if it is acceptable.
> Best,
> --
> Dohyun Kim
> Seoul, Republic of Korea
Thank you for your help. I have downloaded your package, patched 
luatexko-mplib.sty and installed the two files into the directory
that is, the same directory as luamplib.lua and luamplib.sty.
But the compilation failed because of :
! LaTeX Error: File `luatexko-mplib.sty' not found.
I have tried creating a 
directory and storing your two files into it, but the
result is the same. Is there any missing step in the
installation process?

Thank you for your help

Jean Forget

More information about the luatex mailing list